Bug 44701

Summary: [Qt] tst_QWebFrame::hitTestContent() fails on Meego Handset
Product: WebKit Reporter: Benjamin Poulain <benjamin>
Component: Tools / TestsAssignee: Benjamin Poulain <benjamin>
Status: RESOLVED FIXED    
Severity: Major CC: ademar, commit-queue
Priority: P2 Keywords: Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: Other   
OS: Other   
Bug Depends on:    
Bug Blocks: 44675    
Attachments:
Description Flags
Patch to make the test more robust none

Description Benjamin Poulain 2010-08-26 11:32:35 PDT
On Meego Handset, the test tst_QWebFrame::hitTestContent() fails because the hit test content never reports the link: 

FAIL! : tst_QWebFrame::hitTestContent() Compared values are not the same
Actual (result.linkText()):
Expected (QString("link text")): link text
Comment 1 Benjamin Poulain 2010-08-26 11:38:18 PDT
Created attachment 65589 [details]
Patch to make the test more robust

Actually I cannot reproduce the issue on either on my hardware, but it is reported by the integration bot.

I suspect the problem is similar to https://bugs.webkit.org/show_bug.cgi?id=44674, the fonts of the test bots are probably different from mine.
Comment 2 Kenneth Rohde Christiansen 2010-08-26 11:40:58 PDT
Comment on attachment 65589 [details]
Patch to make the test more robust

WebKit/qt/ChangeLog:5
 +          [Qt] tst_QWebFrame::hitTestContent() fails on Meego Handset
I believe it is called "MeeGo"
Comment 3 WebKit Commit Bot 2010-08-26 12:39:35 PDT
Comment on attachment 65589 [details]
Patch to make the test more robust

Rejecting patch 65589 from commit-queue.

benjamin.poulain@nokia.com does not have committer permissions according to http://trac.webkit.org/browser/trunk/WebKitTools/Scripts/webkitpy/common/config/committers.py.

- If you do not have committer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have committer rights please correct the error in WebKitTools/Scripts/webkitpy/common/config/committers.py by adding yourself to the file (no review needed).  Due to bug 30084 the commit-queue will require a restart after your change.  Please contact eseidel@chromium.org to request a commit-queue restart.  After restart the commit-queue will correctly respect your committer rights.
Comment 4 WebKit Commit Bot 2010-08-27 07:03:42 PDT
Comment on attachment 65589 [details]
Patch to make the test more robust

Clearing flags on attachment: 65589

Committed r66219: <http://trac.webkit.org/changeset/66219>
Comment 5 WebKit Commit Bot 2010-08-27 07:03:47 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Ademar Reis 2010-08-27 16:17:49 PDT
Revision r66219 cherry-picked into qtwebkit-2.1 with commit a5aac3cdeddc29cfc8cf9151240417518afc2781