Bug 4427

Summary: Copying transformed text sets some pasteboard flavors incorrectly
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: New BugsAssignee: Dave Hyatt <hyatt>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: darin
Priority: P2    
Version: 420+   
Hardware: Mac   
OS: OS X 10.4   
Attachments:
Description Flags
test case none

Description Alexey Proskuryakov 2005-08-14 01:58:54 PDT
Steps to reproduce:
1. Open the attached testcase
2. Select all and copy the text to clipboard
3. Using Clipboard Viewer, look at NSStringPboardType and NeXT plain ascii pasteboard type. 

Results: these flavors are not correctly transformed to upper case.

Discussion: I have tracked this issue to [WebCoreBridge selectedString] returning text without CSS 
transformations applied (actually, [WebCoreBridge selectedAttributedString] does the same). Perhaps, this 
affects more than just copying...
Comment 1 Alexey Proskuryakov 2005-08-14 02:00:53 PDT
Created attachment 3377 [details]
test case
Comment 2 Darin Adler 2005-08-14 02:02:01 PDT
It's the TextIterator that would have to be fixed.
Comment 3 Darin Adler 2005-08-14 02:03:05 PDT

*** This bug has been marked as a duplicate of 3429 ***

*** This bug has been marked as a duplicate of 3429 ***