Bug 42888

Summary: [WINCE] Buildfix for GraphicsContext
Product: WebKit Reporter: Patrick R. Gansterer <paroga>
Component: PlatformAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: aroben, commit-queue
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Patch
aroben: review+
Patch none

Description Patrick R. Gansterer 2010-07-23 04:35:07 PDT
see patch
Comment 1 Patrick R. Gansterer 2010-07-23 04:35:59 PDT
Created attachment 62410 [details]
Patch
Comment 2 Patrick R. Gansterer 2010-07-23 04:40:34 PDT
(From attachment 62410 [details])
> -    dstRect.move(shadowSize);
> +    dstRect.move(shadowSize.width(), shadowSize.height());
shadowSize is a FloatSize and dstRect is a IntRect
Comment 3 Adam Roben (:aroben) 2010-07-23 08:12:42 PDT
Comment on attachment 62410 [details]
Patch

In the future, it would be helpful for you to use svn-create-patch rather than plain "svn diff" to create your patches. The former does a few things to make the patches slightly easier to read (like putting function names above each chunk).

> @@ -1268,7 +1268,7 @@
>      
>      IntRect dstRect = fillRect;
>      
> -    dstRect.move(shadowSize);
> +    dstRect.move(shadowSize.width(), shadowSize.height());

Is truncating to int really the right thing to do here?

r=me, but I'll wait for an answer before marking this cq+.
Comment 4 Patrick R. Gansterer 2010-07-23 08:20:21 PDT
(In reply to comment #3)
> Is truncating to int really the right thing to do here?
dstRect.inflate(shadowBlur) also casts shadowBlur from float to int.
Comment 5 Adam Roben (:aroben) 2010-07-23 09:53:17 PDT
(In reply to comment #4)
> (In reply to comment #3)
> > Is truncating to int really the right thing to do here?
> dstRect.inflate(shadowBlur) also casts shadowBlur from float to int.

OK, but that doesn't answer the question. Maybe we should be rounding from float to int in both cases instead of truncating?
Comment 6 Patrick R. Gansterer 2010-07-23 10:01:29 PDT
Created attachment 62438 [details]
Patch
Comment 7 Adam Roben (:aroben) 2010-07-23 10:35:24 PDT
Comment on attachment 62438 [details]
Patch

r=me
Comment 8 WebKit Commit Bot 2010-07-23 11:38:34 PDT
Comment on attachment 62438 [details]
Patch

Clearing flags on attachment: 62438

Committed r63989: <http://trac.webkit.org/changeset/63989>
Comment 9 WebKit Commit Bot 2010-07-23 11:38:40 PDT
All reviewed patches have been landed.  Closing bug.