Bug 42520

Summary: Implement more NPRuntime related NPN_ functions
Product: WebKit Reporter: Anders Carlsson <andersca>
Component: New BugsAssignee: Anders Carlsson <andersca>
Severity: Normal CC: webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Description Flags
Patch sam: review+

Description Anders Carlsson 2010-07-18 12:23:00 PDT
Implement more NPRuntime related NPN_ functions
Comment 1 Anders Carlsson 2010-07-18 12:28:14 PDT
Created attachment 61907 [details]
Comment 2 WebKit Review Bot 2010-07-18 12:29:40 PDT
Attachment 61907 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKit2/WebProcess/Plugins/Netscape/NetscapeBrowserFuncs.cpp:290:  NPN_ReleaseObject is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPRuntimeUtilities.cpp:26:  Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
Total errors found: 2 in 5 files

If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Anders Carlsson 2010-07-18 12:44:27 PDT
Committed r63630: <http://trac.webkit.org/changeset/63630>