Bug 42519

Summary: Begin work on NPRuntime support
Product: WebKit Reporter: Anders Carlsson <andersca>
Component: New BugsAssignee: Anders Carlsson <andersca>
Severity: Normal CC: webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Description Flags
Patch mitz: review+

Description Anders Carlsson 2010-07-18 11:50:35 PDT
Begin work on NPRuntime support
Comment 1 Anders Carlsson 2010-07-18 11:51:56 PDT
Created attachment 61905 [details]
Comment 2 WebKit Review Bot 2010-07-18 11:53:51 PDT
Attachment 61905 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKit2/WebProcess/Plugins/Netscape/NetscapeBrowserFuncs.cpp:151:  NPN_GetValue is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapeBrowserFuncs.cpp:154:  A case label should not be indented, but line up with its switch statement.  [whitespace/indent] [4]
Total errors found: 2 in 7 files

If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Anders Carlsson 2010-07-18 11:59:44 PDT
Committed r63629: <http://trac.webkit.org/changeset/63629>