Bug 40911

Summary: [Qt] Performance of the QtScript API is not tested.
Product: WebKit Reporter: Jędrzej Nowacki <jedrzej.nowacki>
Component: JavaScriptCoreAssignee: Jędrzej Nowacki <jedrzej.nowacki>
Status: RESOLVED FIXED    
Severity: Enhancement CC: commit-queue, jedrzej.nowacki, kent.hansen, webkit.review.bot
Priority: P2 Keywords: Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 31863    
Attachments:
Description Flags
Fix v1 none

Description Jędrzej Nowacki 2010-06-21 05:48:05 PDT
It would be nice to compare performance of two QtScript implementations; one which is in Qt with one that lives in Webkit. As both of them are based on JSC performance test should focus on API overhead.

I think that we should create microbenchmarks for all funciton in the API.
Comment 1 Jędrzej Nowacki 2010-06-23 04:05:44 PDT
Created attachment 59500 [details]
Fix v1

The patch introduces micro benchmarks for existing Api.
Comment 2 WebKit Review Bot 2010-06-23 04:07:47 PDT
Attachment 59500 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style', '--no-squash']" exit_code: 1
Last 3072 characters of output:
ject_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:68:  isError_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:71:  toString_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:73:  toNumber_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:75:  toBool_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:77:  toInteger_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:79:  toInt32_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:81:  toUInt32_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:83:  toUInt16_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:85:  toObject_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:88:  equals_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:90:  strictlyEquals_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptvalue/tst_qscriptvalue.cpp:92:  instanceOf_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptengine/tst_qscriptengine.cpp:20:  Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
JavaScriptCore/qt/benchmarks/qscriptengine/tst_qscriptengine.cpp:28:  checkSyntax_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptengine/tst_qscriptengine.cpp:31:  evaluateString_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/qt/benchmarks/qscriptengine/tst_qscriptengine.cpp:33:  evaluateProgram_data is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 27 in 9 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Jędrzej Nowacki 2010-06-23 04:16:35 PDT
(In reply to comment #2)
> If any of these errors are false positives, please file a bug against check-webkit-style.
Reopened 34574
Comment 4 WebKit Commit Bot 2010-06-25 12:57:16 PDT
Comment on attachment 59500 [details]
Fix v1

Clearing flags on attachment: 59500

Committed r61882: <http://trac.webkit.org/changeset/61882>
Comment 5 WebKit Commit Bot 2010-06-25 12:57:20 PDT
All reviewed patches have been landed.  Closing bug.