Bug 39716

Summary: Teach the HTML5 parser how to handle external scripts
Product: WebKit Reporter: Eric Seidel (no email) <eric>
Component: New BugsAssignee: Eric Seidel (no email) <eric>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, dglazkov, tonyg, webkit-ews, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 39259    
Attachments:
Description Flags
very rough work in progress which makes external scripts work
none
slightly better work in progress
none
for adam to look at while I clean it up a bit yet
none
Ready for review abarth: review+

Description Eric Seidel (no email) 2010-05-26 02:47:34 PDT
Teach the HTML5 parser how to handle external scripts
Comment 1 Eric Seidel (no email) 2010-05-26 02:48:34 PDT
I have a work in progress I'll upload.  It causes a bunch of test regressions and is not nearly ready for review yet (but it does handle simple <script src=""> tags!).
Comment 2 Eric Seidel (no email) 2010-05-26 02:50:00 PDT
Created attachment 57084 [details]
very rough work in progress which makes external scripts work
Comment 3 Eric Seidel (no email) 2010-05-26 17:45:02 PDT
Created attachment 57180 [details]
slightly better work in progress
Comment 4 Eric Seidel (no email) 2010-05-26 17:45:43 PDT
Comment on attachment 57180 [details]
slightly better work in progress

Didn't mean to mark this for review, sorry.
Comment 5 Eric Seidel (no email) 2010-05-26 22:56:39 PDT
Created attachment 57196 [details]
for adam to look at while I clean it up a bit yet
Comment 6 Eric Seidel (no email) 2010-05-26 23:38:30 PDT
Created attachment 57199 [details]
Ready for review
Comment 7 Early Warning System Bot 2010-05-26 23:52:55 PDT
Attachment 57199 [details] did not build on qt:
Build output: http://webkit-commit-queue.appspot.com/results/2497061
Comment 8 Adam Barth 2010-05-26 23:59:18 PDT
Comment on attachment 57199 [details]
Ready for review

Thanks for working on this patch.  I know it was painful, but this looks like a good patch to start iterating from.  Please address the verbal comments before landing.

WebCore/html/HTML5TreeBuilder.cpp:120
 +      m_isPaused = false;
I'm not 100% sold on this model, but we'll see how it pans out.
Comment 9 Eric Seidel (no email) 2010-05-27 00:14:34 PDT
Committed r60275: <http://trac.webkit.org/changeset/60275>
Comment 10 WebKit Review Bot 2010-05-27 00:41:51 PDT
Attachment 57199 [details] did not build on chromium:
Build output: http://webkit-commit-queue.appspot.com/results/2514084