Bug 3901

Summary: REGRESSSION: back/forward broken at wsj.com, worked in v185
Product: WebKit Reporter: Trey Matteson <trey>
Component: New BugsAssignee: Maciej Stachowiak <mjs>
Status: RESOLVED FIXED    
Severity: Normal    
Priority: P2    
Version: 412   
Hardware: Mac   
OS: OS X 10.4   
URL: http://www.wsj.com/
Attachments:
Description Flags
proposed patch mjs: review+

Description Trey Matteson 2005-07-07 20:30:29 PDT
(This was originally reported in Radar #4109893)

At some, but not all, pages at wsj.com an extra element is being added to the back/forward list.  This 
causes the end user effect that clicking back does not take you back.

I've noticed it on different pages.  Currently it reproduces using the home page, but I suspect that 
might change since it is not consistent on all pages of the site.  The steps:

Open a new Safari window.
Goto http://online.wsj.com/public/us.
Press and hold the back button.  Notice there is an item for "WSJ Home", but that should not be there 
since you are currently at that site.

When there is an extra b/f item, it looks like:

http://cmhtml.overture.com/d/search/p/wsj/html/jsads/?
Partner=wsj_home_ctxt&adwd=620&adht=250&ctxtUrl=no_url&ctxtCat=home&css_url=http://
cmhtml.overture.com/partner/css/wsj4.css&tg=1&cb=1115325157576

I tried the same steps today on version 185 of Safari running on 10.3.5, and did not see the bug.
Comment 1 Trey Matteson 2005-07-07 21:01:20 PDT
Created attachment 2857 [details]
proposed patch
Comment 2 Maciej Stachowiak 2005-07-07 21:08:49 PDT
Comment on attachment 2857 [details]
proposed patch

r=me

great fix!
Comment 3 Joost de Valk (AlthA) 2005-07-08 10:58:36 PDT
I propose Trey for canconfirm, and i'll make this bug confirmed :). Maciej: next time when you review+ a 
patch, maybe it's easier to do this as well? :P
Comment 4 Vicki Murley 2005-07-08 11:55:12 PDT
I committed this fix.
Comment 5 Mark Rowe (bdash) 2007-05-19 00:38:03 PDT
Bug 13772 claims that this has been reintroduced.