Bug 38243

Summary: Don't run transitions to/from 'auto' values
Product: WebKit Reporter: Simon Fraser (smfr) <simon.fraser>
Component: Layout and RenderingAssignee: Simon Fraser (smfr) <simon.fraser>
Status: RESOLVED FIXED    
Severity: Normal CC: buildbot, cmarrin, dino, graouts, rniwa, simon.fraser
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: OS X 10.5   
Attachments:
Description Flags
Patch
dino: review+, buildbot: commit-queue-
Archive of layout-test-results from ews101 for mac-yosemite
none
Archive of layout-test-results from ews112 for mac-yosemite none

Description Simon Fraser (smfr) 2010-04-27 22:52:11 PDT
If a Length is changing to or from an 'auto' value, we treat the auto value as zero, and so do a stupid animation.

We should just avoid running such animations.
Comment 1 Simon Fraser (smfr) 2010-12-03 15:23:43 PST
I tried this, but the problem is that transitions of 'left' on position: relative elements are fairly common, and the initial value for 'left' is 'auto'.
Comment 2 Simon Fraser (smfr) 2011-02-24 10:59:33 PST
See also bug 16020.
Comment 3 Simon Fraser (smfr) 2016-05-02 18:38:06 PDT
rdar://problem/20904225
Comment 4 Simon Fraser (smfr) 2016-05-02 18:43:20 PDT
Created attachment 277958 [details]
Patch
Comment 5 Build Bot 2016-05-02 19:29:32 PDT
Comment on attachment 277958 [details]
Patch

Attachment 277958 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/1258680

New failing tests:
transitions/default-timing-function.html
Comment 6 Build Bot 2016-05-02 19:29:36 PDT
Created attachment 277962 [details]
Archive of layout-test-results from ews101 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews101  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 7 Build Bot 2016-05-02 19:41:51 PDT
Comment on attachment 277958 [details]
Patch

Attachment 277958 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/1258695

New failing tests:
transitions/default-timing-function.html
Comment 8 Build Bot 2016-05-02 19:41:55 PDT
Created attachment 277963 [details]
Archive of layout-test-results from ews112 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews112  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 9 Simon Fraser (smfr) 2016-05-02 20:39:48 PDT
http://trac.webkit.org/changeset/200360