|Summary:||Rename QTKit based media engine class name|
|Product:||WebKit||Reporter:||Eric Carlson <eric.carlson>|
|Component:||Media||Assignee:||Eric Carlson <eric.carlson>|
|Severity:||Normal||CC:||abarth, ademar, eric, pnormand, rniwa, webkit.review.bot|
|Version:||528+ (Nightly build)|
|OS:||OS X 10.6|
|Bug Depends on:|
Description Eric Carlson 2010-03-26 08:35:29 PDT
As noted in https://bugs.webkit.org/show_bug.cgi?id=36654, it is possible to use a GStreamer based media engine on OSX as well as the QTKit based media engine so we should use a non-generic class name.
Comment 1 Philippe Normand 2010-03-26 10:50:48 PDT
Additionnally I think it would be good to have a WTF_USE_... define to enable the QTKit player and same for QuickTime (or whatever is currently used on the windows port).
Comment 2 Tor Arne Vestbø 2010-09-28 09:23:20 PDT
Qt backends were renamed in <http://trac.webkit.org/changeset/68526>
Comment 3 WebKit Review Bot 2010-09-28 10:11:18 PDT
http://trac.webkit.org/changeset/68526 might have broken Qt Windows 32-bit Debug The following changes are on the blame list: http://trac.webkit.org/changeset/68523 http://trac.webkit.org/changeset/68524 http://trac.webkit.org/changeset/68525 http://trac.webkit.org/changeset/68526 http://trac.webkit.org/changeset/68527 http://trac.webkit.org/changeset/68528 http://trac.webkit.org/changeset/68529 http://trac.webkit.org/changeset/68530 http://trac.webkit.org/changeset/68531
Comment 5 Daniel Bates 2010-11-14 12:38:21 PST
Comment on attachment 73830 [details] Proposed patch Marking this attachment as a patch since it is a patch and it is flagged for review. Moreover, this will cause the EWS bots to build with this patch.
Comment 7 Ryosuke Niwa 2010-11-16 21:41:22 PST
This change might be responsible for some test failures: http://build.webkit.org/results/SnowLeopard%20Intel%20Release%20(Tests)/r72115%20(20918)/results.html All of the failures seem to be caused by failing to load some resource. Could you look into this?
Comment 8 Ryosuke Niwa 2010-11-16 21:46:23 PST
(In reply to comment #7) > This change might be responsible for some test failures: > http://build.webkit.org/results/SnowLeopard%20Intel%20Release%20(Tests)/r72115%20(20918)/results.html > > All of the failures seem to be caused by failing to load some resource. Could you look into this? Oops, this was a false alert. The failure was caused by r72115, not r72117. Sorry.
Comment 9 Eric Carlson 2010-11-16 21:49:02 PST
This changed the name of the OS X media engine class. The code change is *only* used by HTMLMediaElement, it has absolutely nothing to do with the loader.
Comment 10 Ademar Reis 2011-01-24 12:19:04 PST
Revision r68526 cherry-picked into qtwebkit-2.2 with commit 600bc9b <http://gitorious.org/webkit/qtwebkit/commit/600bc9b>