Bug 36191

Summary: [Qt] GraphicsLayer: fix test regressions
Product: WebKit Reporter: Noam Rosenthal <noam>
Component: Layout and RenderingAssignee: Noam Rosenthal <noam>
Status: CLOSED FIXED    
Severity: Normal CC: hausmann, jesus, ossy
Priority: P3 Keywords: Qt
Version: 528+ (Nightly build)   
Hardware: PC   
OS: All   
Bug Depends on: 36216, 36219    
Bug Blocks: 35784    

Description Noam Rosenthal 2010-03-16 14:02:25 PDT
Some regressions were found in test animations.
We need to check if those are actual regressions or a test issue, and fix.
Comment 2 Jesus Sanchez-Palencia 2010-03-16 14:11:50 PDT
Is this Mac OS specific?
If not, could you please change the OS and assign this to webkit-qt-unassigned@trolltech.com so we don't add another item to the untriaged bugs list ?

(I can't edit the bugzilla entry, otherwise I would edit this.)
Comment 3 Noam Rosenthal 2010-03-16 14:16:03 PDT
Done.
Comment 4 Noam Rosenthal 2010-03-17 05:44:01 PDT
When running http://trac.webkit.org/export/55955/trunk/LayoutTests/animations/simultaneous-start-left.html it passes.
The other two bugs also fail on Safari windows, and are related to new and undocumented css properties.
Deferring to P3 for now.
Comment 5 Csaba Osztrogon√°c 2010-03-17 05:54:45 PDT
Failing tests skipped by http://trac.webkit.org/changeset/56106 ,
please unskip them with fix.
Comment 6 Noam Rosenthal 2010-03-17 05:59:02 PDT
For now we'll leave them as skipped - which is the right way to treat tests for new webkit features that we don't support yet in Qt :) 
For some of these tests it's not a regression since they were only added a couple of weeks ago.
Comment 7 Noam Rosenthal 2010-03-24 14:37:39 PDT
36216 is a brand new CSS feature - no point in making support for it a blocker.
Comment 8 Csaba Osztrogon√°c 2010-04-06 12:43:13 PDT
I don't understand exactly why they aren't regressions. I only see these tests passed before enabling accelerated compositing by default, and failed after the patch landed. What is it if not a regression?
Comment 9 Noam Rosenthal 2010-04-06 12:52:58 PDT
To be more specific:

* animations/fill-mode-transform.html

This is a new feature (added mid March) that we need to support in Qt AC. Of course a new feature that Apple adds that requires AC support is going to fail with Qt, because we simply haven't implemented support for that feature yet. Classic case for temporary skip and definitely not a "regression".

* animations/play-state.html

Fixed, see 36219

animations/simultaneous-start-left.html

I couldn't reproduce it - waiting till we have proper QGraphicsWebView support in DRT to look into it again.

In general we're not running tests on QGraphicsWebView regularly - until we do that there's no point in treating AC in a special way. Once all the DRT tests work on QGraphicsWebView, I can look at the delta with AC.
Comment 10 Noam Rosenthal 2010-04-16 16:25:01 PDT
A fix is now coming.
Comment 11 Noam Rosenthal 2010-04-21 15:27:24 PDT
all underlying bugs have been fixed.