Bug 35454

Summary: webkit-build could pass unknown arguments to autogen.sh
Product: WebKit Reporter: arno. <a.renevier>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, commit-queue, gustavo, pnormand, xan.lopez
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Attachments:
Description Flags
patch v1 none

Description arno. 2010-02-26 14:18:38 PST
Hi,
currently, webkit-build parses argument it knows about, and reformats them to pass them to autogen.sh.
But there is no way to pass arguments to autogen.sh if webkit-build does not know about them.
For example, we may want, occasionally, to call autogen.sh with --enable-gtk-doc argument.

Maybe we can just pass unknown arguments to autogen.sh, in the same way qt passes unknown arguments to qmake.
Comment 1 arno. 2010-02-26 14:22:40 PST
Created attachment 49643 [details]
patch v1
Comment 2 Adam Barth 2010-02-27 01:58:18 PST
Adding some GTK folks.
Comment 3 Xan Lopez 2010-02-27 02:38:47 PST
Comment on attachment 49643 [details]
patch v1

Makes sense to me.
Comment 4 Xan Lopez 2010-02-27 02:42:33 PST
*** Bug 35244 has been marked as a duplicate of this bug. ***
Comment 5 WebKit Commit Bot 2010-03-01 16:05:40 PST
Comment on attachment 49643 [details]
patch v1

Clearing flags on attachment: 49643

Committed r55384: <http://trac.webkit.org/changeset/55384>
Comment 6 WebKit Commit Bot 2010-03-01 16:05:45 PST
All reviewed patches have been landed.  Closing bug.