Bug 34361

Summary: REGRESSION(canvas editor): Text selection does not work correctly when source view is scrolled horizontally
Product: WebKit Reporter: Mark Rowe (bdash) <mrowe>
Component: Web Inspector (Deprecated)Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bweinstein, joepeck, keishi, mitz, mjs, pfeldman, pmuellr, rik, timothy
Priority: P2 Keywords: InRadar, Regression
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   

Description Mark Rowe (bdash) 2010-01-29 18:25:31 PST
In r54084 I've noticed that text selection by dragging either refuses to work or selects the incorrect text when the source view is scrolled horizontally.  This doesn't happen in a build of WebKit from earlier in the week (the source view wraps lines rather than providing for scrolling).

Steps to reproduce:
1) Inspect a page, then switch to the Content view of the main resource.
2) Resize the window slightly to ensure that you have a horizontal scrollbar.
3) Scroll to the right by a small amount.
4) Attempt to select some text in the source using the mouse.

Result:
Depending on how far you're scrolled and which text you attempt to select, you'll either end up creating a selection to the right of where you intended, or no selection at all.
Comment 1 Mark Rowe (bdash) 2010-01-29 18:44:15 PST
<rdar://problem/7594374>