Bug 34240

Summary: LayoutTests/fast/forms/input-valueasnumber-*.html failures on some platforms
Product: WebKit Reporter: Kent Tamura <tkent>
Component: FormsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bweinstein, commit-queue
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Windows Vista   
Bug Depends on: 32696    
Bug Blocks:    
Attachments:
Description Flags
Patch fishd: review+, commit-queue: commit-queue-

Description Kent Tamura 2010-01-27 20:37:56 PST
* input-valueasnumber-datetime.html fails on Windows
> FAIL setValueAsNumberAndGetValue(275760, 8, 13, 0, 0, 0, 1) should be 275760-09-13T00:00:00.001Z. Was 275760-09-13T00:00:00.002Z.

* input-valueasnumber-datetimelocal.html fails on Windows
> FAIL setValueAsNumberAndGetValue(275760, 8, 13, 0, 0, 0, 1) should be 275760-09-13T00:00:00.001. Was 275760-09-13T00:00:00.002.

* input-valueasnumber-{datetime,date,month,datetimelocal}.html fail on all Chromium platforms.
 Issues on dates later than 275760-09-13T00:00Z
Comment 1 Kent Tamura 2010-01-27 22:01:19 PST
Created attachment 47591 [details]
Patch
Comment 2 Kent Tamura 2010-01-27 22:04:51 PST
Failures on Windows were caused by a bug of round() in MathExtra.h. I'll fix it later.
Comment 3 WebKit Commit Bot 2010-01-28 01:02:01 PST
Comment on attachment 47591 [details]
Patch

Rejecting patch 47591 from commit-queue.

Failed to run "['git', 'svn', 'dcommit']" exit_code: 1
Committing to http://svn.webkit.org/repository/webkit/trunk ...
	D	LayoutTests/platform/win/fast/forms/input-valueasnumber-datetime-expected.txt
RA layer request failed: CHECKOUT of '/repository/webkit/!svn/ver/53959/trunk/LayoutTests/platform/win/fast/forms': 500 Internal Server Error (http://svn.webkit.org) at /usr/local/git/libexec/git-core/git-svn line 558


Full output: http://webkit-commit-queue.appspot.com/results/216564
Comment 4 Kent Tamura 2010-01-28 01:11:04 PST
Landed manually as r53991.
Comment 5 Darin Adler 2010-01-29 09:42:14 PST
Comment on attachment 47591 [details]
Patch

Why are we disabling these tests? Are we OK with WebKit working differently on these edge cases with and without V8?
Comment 6 Kent Tamura 2010-01-31 19:19:02 PST
(In reply to comment #5)
> (From update of attachment 47591 [details])
> Why are we disabling these tests? Are we OK with WebKit working differently on
> these edge cases with and without V8?

This difference is not acceptable.
Both of JSC behavior and V8 behavior don't conform to ECMA-262.  I'll fix them and revive these tests.