Bug 34222

Summary: http/tests/navigation/anchor-basic.html is flaky on Snow Leopard Release Bot
Product: WebKit Reporter: Eric Seidel (no email) <eric>
Component: Tools / TestsAssignee: Tony Chang <tony>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, aroben, ggaren, mihaip, ossy, rniwa, sam, tony, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 33292    
Attachments:
Description Flags
Patch
none
Patch for landing none

Description Eric Seidel (no email) 2010-01-27 12:01:27 PST
http/tests/navigation/anchor-basic.html timed out on Snow Leopard Release Bot

http://build.webkit.org/results/SnowLeopard%20Intel%20Release%20(Tests)/r53938%20(4875)/results.html

Been here for a long time:
http://trac.webkit.org/browser/trunk/LayoutTests/http/tests/navigation/anchor-basic.html
Comment 1 Ryosuke Niwa 2011-09-16 13:34:10 PDT
See new diff:
http://build.webkit.org/results/SnowLeopard%20Intel%20Release%20(Tests)/r95284%20(33129)/http/tests/navigation/anchor-basic-pretty-diff.html

This test fails every now and then on Snow Leopard bots.  Note that this test is skipped on Leopard (see the bug 34222).
Comment 2 Eric Seidel (no email) 2011-09-16 13:37:45 PDT
Do we know what other test result its showing there?  It seems like some other test might be polluting this one?
Comment 3 Ryosuke Niwa 2011-09-19 09:43:17 PDT
(In reply to comment #2)
> Do we know what other test result its showing there?  It seems like some other test might be polluting this one?

http/tests/multipart/stop-crash.html
Comment 4 Eric Seidel (no email) 2011-09-19 10:50:07 PDT
That test is even older.
http://trac.webkit.org/browser/trunk/LayoutTests/http/tests/multipart/stop-crash.html

We obviously could disable one or both of these tests, but best would be to understand the interaction going on and fix the underlying bug in WebCore or DumpRenderTree.
Comment 5 Tony Chang 2011-09-27 15:38:25 PDT
Created attachment 108918 [details]
Patch
Comment 6 Ryosuke Niwa 2011-09-27 16:53:19 PDT
Comment on attachment 108918 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=108918&action=review

> LayoutTests/ChangeLog:10
> +        Add waitUntilDone/notifyDone to eliminate flakiness on mac.  Without
> +        it, the img onload handler doesn't always run.  Also reduce the
> +        multipart timeout (should help to unblock other http requests).

Could you re-format the comment so that it doesn't use double-space? Also it seems awkward for "it" to appear at the beginning of a line or "the" to appear at the end of a line.
Comment 7 Tony Chang 2011-09-27 16:56:21 PDT
Created attachment 108935 [details]
Patch for landing
Comment 8 WebKit Review Bot 2011-09-27 18:01:06 PDT
Comment on attachment 108935 [details]
Patch for landing

Clearing flags on attachment: 108935

Committed r96174: <http://trac.webkit.org/changeset/96174>
Comment 9 WebKit Review Bot 2011-09-27 18:01:11 PDT
All reviewed patches have been landed.  Closing bug.
Comment 10 Csaba Osztrogon√°c 2011-09-27 23:47:47 PDT
It make http/tests/multipart/stop-crash.html fail on the GTK and the Qt bots:

--- /var/lib/buildbot/build/gtk-linux-32-release/build/layout-test-results/http/tests/multipart/stop-crash-expected.txt 
+++ /var/lib/buildbot/build/gtk-linux-32-release/build/layout-test-results/http/tests/multipart/stop-crash-actual.txt 
@@ -1,6 +1,7 @@
+FAIL: Timed out waiting for notifyDone to be called
 Test for http://bugs.webkit.org/show_bug.cgi?id=13360 REGRESSION: Crash closing live web cam viewer page.
 
 If WebKit does not assert or crash after the test, then it passed.
 
 
-PASS
+
Comment 11 Csaba Osztrogon√°c 2011-09-28 01:06:33 PDT
It seems it is a bug somewhere in GTK and Qt port.
New bug report filed: https://bugs.webkit.org/show_bug.cgi?id=68979
Comment 12 Tony Chang 2011-09-28 09:32:15 PDT
http/tests/navigation/anchor-basic.html has passed every run after this patch landed.  Looks like that was the problem.

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=http%2Ftests%2Fnavigation%2Fanchor-basic.html&group=%40ToT%20-%20webkit.org