Bug 33615

Summary: Rename InjectedScript
Product: WebKit Reporter: Geoffrey Garen <ggaren>
Component: WebCore JavaScriptAssignee: Nobody <webkit-unassigned>
Status: NEW ---    
Severity: Normal CC: bweinstein, joepeck, keishi, pfeldman, pmuellr, rik, ukai, yurys
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   

Description Geoffrey Garen 2010-01-13 12:19:18 PST
From https://bugs.webkit.org/show_bug.cgi?id=33469:

> 1. I don't think "InjectedScript", which is a fairly general phrase, is a good
> name to give to this technology. I'd prefer a name that conveyed the fact that
> this technology is only safe to use in limited circumstances. How about
> "InspectorHost" (inside the inspected page) and "InspectorClient" (the Web
> Inspector UI).
I agree with you that the naming is not the best. Currently the inspector
front-end delegate is called InjectedScriptHost. We should come up with
something more specific.