Bug 33421

Summary: [GTK] Crash when closing/switching a website
Product: WebKit Reporter: Sebastian Dröge (slomo) <slomo>
Component: ImagesAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: gns
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   

Description Sebastian Dröge (slomo) 2010-01-09 05:52:42 PST
Hi,
sometimes webkit/GTK (GIT as of yesterday) crashes when closing or switching a website. Not 100% reproducible but happens quite often.

Backtrace:

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff512fd33 in WTF::fastFree(void*) ()
   from /usr/local/lib/libwebkit-1.0.so.2
(gdb) bt
#0  0x00007ffff512fd33 in WTF::fastFree(void*) ()
   from /usr/local/lib/libwebkit-1.0.so.2
#1  0x00007ffff4f880ae in WebCore::JPEGImageDecoder::~JPEGImageDecoder() ()
   from /usr/local/lib/libwebkit-1.0.so.2
#2  0x00007ffff4c38047 in WebCore::ImageSource::clear(bool, unsigned long, WebCore::SharedBuffer*, bool) () from /usr/local/lib/libwebkit-1.0.so.2
#3  0x00007ffff4c23269 in WebCore::BitmapImage::~BitmapImage() ()
   from /usr/local/lib/libwebkit-1.0.so.2
#4  0x00007ffff4b507b6 in WebCore::CachedImage::destroyDecodedData() ()
   from /usr/local/lib/libwebkit-1.0.so.2
#5  0x00007ffff4c20886 in WebCore::ThreadTimers::sharedTimerFiredInternal() ()
   from /usr/local/lib/libwebkit-1.0.so.2
#6  0x00007ffff4f79342 in WebCore::timeout_cb(void*) ()
   from /usr/local/lib/libwebkit-1.0.so.2
#7  0x00007ffff13ba18b in g_timeout_dispatch (source=0xf2f850, 
    callback=0x7fffe2331000, user_data=0x7fffdb169b8000)
    at /home/slomo/projects/debian/pkg-gnome/desktop/experimental/build-area/glib2.0-2.23.1/glib/gmain.c:3396
#8  0x00007ffff13b9a7e in g_main_dispatch (context=0x71b6f0)
    at /home/slomo/projects/debian/pkg-gnome/desktop/experimental/build-area/glib2.0-2.23.1/glib/gmain.c:1960
#9  IA__g_main_context_dispatch (context=0x71b6f0)
    at /home/slomo/projects/debian/pkg-gnome/desktop/experimental/build-area/gli---Type <return> to continue, or q <return> to quit---
b2.0-2.23.1/glib/gmain.c:2513
#10 0x00007ffff13bd438 in g_main_context_iterate (context=0x71b6f0, 
    block=<value optimized out>, dispatch=<value optimized out>, 
    self=<value optimized out>)
    at /home/slomo/projects/debian/pkg-gnome/desktop/experimental/build-area/glib2.0-2.23.1/glib/gmain.c:2591
#11 0x00007ffff13bd895 in IA__g_main_loop_run (loop=0x7a4f80)
    at /home/slomo/projects/debian/pkg-gnome/desktop/experimental/build-area/glib2.0-2.23.1/glib/gmain.c:2799
#12 0x00007ffff3e3b627 in IA__gtk_main () at /gtk+2.0-2.19.2/gtk/gtkmain.c:1219
#13 0x0000000000435cef in main (argc=1, argv=0x7fffffffe2c8) at ephy-main.c:778
Comment 1 Gustavo Noronha (kov) 2010-01-15 15:12:48 PST
Hey, you may want to check https://bugs.webkit.org/show_bug.cgi?id=33746, since you said my original patch fixes many crashes you had =). That replicates the same approach as the original patch's.
Comment 2 Sebastian Dröge (slomo) 2010-01-19 02:54:11 PST

*** This bug has been marked as a duplicate of bug 32900 ***