Bug 33048

Summary: [V8] Auto-generate and split DerivedSourcesAllInOne.cpp
Product: WebKit Reporter: Yaar Schnitman <yaar>
Component: WebKit Misc.Assignee: Yaar Schnitman <yaar>
Status: RESOLVED FIXED    
Severity: Normal CC: bradnelson, dglazkov, dpranke, japhet, jorlow, snej, steveblock, webkit.review.bot, yaar
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 32630    
Attachments:
Description Flags
Patch 1
none
Patch
none
Patch
none
Patch
none
Patch
none
Patch
dglazkov: review+
Delete the old DerivedSourcesAllInOne.cpp dglazkov: review+

Description Yaar Schnitman 2009-12-30 03:36:51 PST
DerivedSourcesAllInOne.cpp is maintained manually, which is cumbersome and causes frequent chromium breakage. A new WebCore.gyp action is introduced to automatically generate this file.

Chromium issue: http://code.google.com/p/chromium/issues/detail?id=16439
Comment 1 Yaar Schnitman 2009-12-30 03:43:48 PST
Created attachment 45651 [details]
Patch 1

This patch does the work, but depends on a necessary fix to gyp.
Comment 2 Yaar Schnitman 2009-12-30 03:53:22 PST
Opened a gyp issue: http://code.google.com/p/gyp/issues/detail?id=134
Comment 3 Dimitri Glazkov (Google) 2009-12-30 12:41:13 PST
This looks awesome. I am no gyp wizard, but I have lots of ideas :)

1) I wonder if it's possible to only invoke this action when a certain condition is true? We only need this conglomeration when doing whole-program-optimization Release builds and that's an exceptional configuration, rather than the standard one.

2) It would super-great to build this as a generic conglomerator that work on any directory, like WebCore/svg and such. Is it possible?
Comment 4 Dimitri Glazkov (Google) 2010-02-17 07:55:46 PST
*** Bug 32128 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Orlow 2010-02-17 08:02:21 PST
Yaar, any eta on getting this in?
Comment 6 Yaar Schnitman 2010-02-17 17:11:20 PST
Created attachment 48951 [details]
Patch
Comment 7 Yaar Schnitman 2010-02-25 18:32:57 PST
Created attachment 49557 [details]
Patch
Comment 8 Yaar Schnitman 2010-02-25 18:35:37 PST
The file is auto-generated and split into 8 pieces, to reduce compilation units size and allow parallel compilation.
Comment 9 Yaar Schnitman 2010-02-25 18:36:43 PST
Created attachment 49558 [details]
Patch
Comment 10 Yaar Schnitman 2010-02-25 18:37:29 PST
Comment on attachment 49558 [details]
Patch

Gyp changes were landed, and this is ready to go (pending review of course).
Comment 11 WebKit Review Bot 2010-02-25 19:02:50 PST
Attachment 49558 [details] did not build on chromium:
Build output: http://webkit-commit-queue.appspot.com/results/314039
Comment 12 Yaar Schnitman 2010-02-25 19:14:30 PST
Created attachment 49560 [details]
Patch
Comment 13 Yaar Schnitman 2010-02-25 19:15:25 PST
Comment on attachment 49560 [details]
Patch

Had to increment gyp's version on the webkit port as well.
Comment 14 WebKit Review Bot 2010-02-25 19:20:42 PST
Attachment 49560 [details] did not build on chromium:
Build output: http://webkit-commit-queue.appspot.com/results/313151
Comment 15 Yaar Schnitman 2010-02-26 13:20:12 PST
Created attachment 49631 [details]
Patch
Comment 16 Dimitri Glazkov (Google) 2010-02-26 13:23:21 PST
Comment on attachment 49631 [details]
Patch

Ok. Please watch the canaries. They are dead at the moment.
Comment 17 Nate Chapin 2010-03-11 16:31:59 PST
Created attachment 50558 [details]
Delete the old DerivedSourcesAllInOne.cpp
Comment 18 Dimitri Glazkov (Google) 2010-03-11 16:34:32 PST
Comment on attachment 50558 [details]
Delete the old DerivedSourcesAllInOne.cpp

ok.
Comment 19 Nate Chapin 2010-03-16 16:02:14 PDT
http://trac.webkit.org/changeset/56063