Bug 32468

Summary: [bzt] Add AbstractPatchSequencingCommand to remove redundant code
Product: WebKit Reporter: Adam Barth <abarth>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Severity: Normal CC: eric
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on: 32467    
Bug Blocks: 32469    
Description Flags
Patch none

Description Adam Barth 2009-12-12 01:32:46 PST
Redundant code is bad.  This patch moves us towards more declarative commands.
Comment 1 Adam Barth 2009-12-12 01:33:45 PST
Created attachment 44735 [details]
Comment 2 Eric Seidel (no email) 2009-12-14 16:23:10 PST
Comment on attachment 44735 [details]

I'm confused by this line:
 126         return step_sequence, step_sequence.options()
Comment 3 Eric Seidel (no email) 2009-12-14 21:22:24 PST
Comment on attachment 44735 [details]

So I don't understand why options need to be returned separately from the sequence, but otherwise this looks fine.

We really need to kill all these "show_in_main_help = false" at some point.
Comment 4 Adam Barth 2009-12-14 21:37:51 PST
Good point.  I'll fix that at the end.
Comment 5 Adam Barth 2009-12-14 21:38:18 PST
Comment on attachment 44735 [details]

Clearing flags on attachment: 44735

Committed r52132: <http://trac.webkit.org/changeset/52132>
Comment 6 Adam Barth 2009-12-14 21:38:24 PST
All reviewed patches have been landed.  Closing bug.