Bug 31980

Summary: REGRESSION (r49757): masking-mask-01-b.svg rendered incorrectly
Product: WebKit Reporter: Yuta Kitamura <yutak>
Component: SVGAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, krit, zimmermann
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Attachments:
Description Flags
Expected and current rendering
none
Test case for SVG mask
none
fix of SVG Mask none

Description Yuta Kitamura 2009-11-30 03:12:35 PST
Created attachment 44014 [details]
Expected and current rendering

LayoutTests/svg/W3C-SVG-1.1/masking-mask-01-b.svg

This test has been failing since r49757. SVG masks are not working correctly.
Comment 1 Yuta Kitamura 2009-11-30 03:14:13 PST
Dirk, do you have any idea on this?
Comment 2 Dirk Schulze 2009-11-30 03:33:44 PST
I can reproduce this in trunk. I'm currently building r49757. If this comes with this commit, we still have a bug in the calculation of  the mask region. I'll take a look at it.
Comment 3 Dirk Schulze 2009-11-30 05:07:34 PST
Created attachment 44016 [details]
Test case for SVG mask

It looks like the combination of maskUnits="userSpaceOnUse" with maskContentUnits="userSpaceOnUse" on a mask element doesn't work atm.
Comment 4 Dirk Schulze 2009-11-30 08:49:19 PST
Created attachment 44022 [details]
fix of SVG Mask

This should fix SVG Mask for sure this time (hopefully ;-)). I added a more complex test of all combinations of maskUnits and maskContentUnits. LayoutTests/svg/W3C-SVG-1.1/masking-mask-01-b.svg works again now.
Comment 5 Nikolas Zimmermann 2009-11-30 09:16:10 PST
Comment on attachment 44022 [details]
fix of SVG Mask

LGTM. r=me.
Comment 6 WebKit Commit Bot 2009-11-30 09:25:07 PST
Comment on attachment 44022 [details]
fix of SVG Mask

Clearing flags on attachment: 44022

Committed r51496: <http://trac.webkit.org/changeset/51496>
Comment 7 WebKit Commit Bot 2009-11-30 09:25:12 PST
All reviewed patches have been landed.  Closing bug.
Comment 8 Yuta Kitamura 2009-11-30 18:03:12 PST
Confirmed. Thanks!