Bug 28461

Summary: transitions/change-values-during-transition.html fails intermittently
Product: WebKit Reporter: Mark Rowe (bdash) <mrowe>
Component: New BugsAssignee: Chris Marrin <cmarrin>
Status: RESOLVED FIXED    
Severity: Normal CC: abecsi, cmarrin, commit-queue, eric, mihai, ossy, simon.fraser
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 37048    
Attachments:
Description Flags
Patch none

Description Mark Rowe (bdash) 2009-08-19 09:55:40 PDT
transitions/change-values-during-transition.html has been failing intermittently on the new leaks bot: <http://build.webkit.org/results/SnowLeopard%20Intel%20Leaks/r47504%20(13)/transitions/change-values-during-transition-pretty-diff.html>.  This is presumably due to the extra overhead that comes from running with MallocStackLogging enabled.  We should make the test more robust so that it doesn't fail in this manner.
Comment 1 Eric Seidel (no email) 2009-09-30 23:10:13 PDT
Another one tonight:
http://build.webkit.org/results/SnowLeopard%20Intel%20Leaks/r48958%20(1067)/results.html

Seems to be a bunch of transition related intermittent failures on the SnowLeopard bot, maybe they all have one root cause?

transitions/change-values-during-transition.html:
http://build.webkit.org/results/SnowLeopard%20Intel%20Leaks/r48958%20(1067)/results.html

transitions/cancel-transition.html:
http://build.webkit.org/results/SnowLeopard%20Intel%20Leaks/r48945%20(1056)/results.html

I was looking at adding the SnowLeopard bots to the list of bots to block commits from the commit-queue this evening.  Looks like they're not quite ready, this bug being one of the blockers. (bugzilla-tool, and thus the commit-queue, will not allow one to commit if the bots are red.  Currently the SnowLeopard bots are not in the set of bots it checks, but once they are stable green I would like them to be.)
Comment 2 Mihai Parparita 2010-08-17 15:09:19 PDT
Created attachment 64641 [details]
Patch
Comment 3 Mihai Parparita 2010-08-17 15:10:14 PDT
I just ran into this while trying to land 44086 via the commit queue. The attached patch should hopefully make it less flaky.
Comment 4 Chris Marrin 2010-08-17 15:25:45 PDT
Comment on attachment 64641 [details]
Patch

r=me. This is a good technique for many of these transition/animation tests. We might want to use it elsewhere, or even put it into one of the JS helpers.
Comment 5 WebKit Commit Bot 2010-08-17 16:06:21 PDT
Comment on attachment 64641 [details]
Patch

Rejecting patch 64641 from review queue.

cmarrin@apple.com does not have reviewer permissions according to http://trac.webkit.org/browser/trunk/WebKitTools/Scripts/webkitpy/common/config/committers.py.

- If you do not have reviewer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have reviewer rights please correct the error in WebKitTools/Scripts/webkitpy/common/config/committers.py by adding yourself to the file (no review needed).  Due to bug 30084 the commit-queue will require a restart after your change.  Please contact eseidel@chromium.org to request a commit-queue restart.  After restart the commit-queue will correctly respect your reviewer rights.
Comment 6 Dimitri Glazkov (Google) 2010-08-17 16:31:47 PDT
Comment on attachment 64641 [details]
Patch

Chris, you need to teach commit-queue a lesson! :P
Comment 7 WebKit Commit Bot 2010-08-17 16:58:15 PDT
Comment on attachment 64641 [details]
Patch

Clearing flags on attachment: 64641

Committed r65575: <http://trac.webkit.org/changeset/65575>
Comment 8 WebKit Commit Bot 2010-08-17 16:58:20 PDT
All reviewed patches have been landed.  Closing bug.