|Summary:||Inspector: Resources Search Should Search Only Filtered Resources|
|Product:||WebKit||Reporter:||Joseph Pecoraro <joepeck>|
|Component:||Web Inspector (Deprecated)||Assignee:||Alexander Pavlov (apavlov) <apavlov>|
|Severity:||Normal||CC:||aroben, kmccullough, rik, timothy|
|Version:||528+ (Nightly build)|
Description Joseph Pecoraro 2009-08-13 19:01:06 PDT
Created attachment 34802 [details] IMAGE: "Filtered Out" Resource Appears During a Search Example: 1. Choose the "Images" Filter 2. Search for "color" Its likely that CSS Stylesheets will start to appear in the sidebar, even though they should have been filtered.
Comment 1 Joseph Pecoraro 2009-08-19 13:00:02 PDT
I didn't set that patch as r? because I had some other things that I was wondering about: Another developer emailed me with some feedback about the "webkit cookie api". He listed a number of good points. I think I should work on cleaning up and drafting a good cookie api now, rather then adding it piecewise like I have been doing. Some of the suggestions that came out of our email exchange where: - Change the name of "getRawCookies" to something better like "cookiesList", and apparently returning a bool is not consistent with other sections. This seems more appropriate: void cookiesList(const Document* document, const KURL& url, Vector<Cookie>& cookiesList, bool& implemented = false); - Change the name of "deleteCookie" to "deleteCookieByName" which is more correct. I think this is also a good idea. - It would be nice to prepare for adding support for Creating/Modifying cookies. This behavior must already be possible via CookieJar's already existing setCookies(.., .., String). I think it would be appropriate to provide an addCookie convenience function and possibly updateCookieByName. Or should these be avoided in favor of specific calls to setCookies? - He raised a good point as well => "On this topic what is the goal of the Cookie.h class? The file didn't contain any comments. Is it just for the inspector currently? Any long term plans? It would be nice to have a unified string -> cookie parser for all webkit as it is such as messy job and every port does it a tiny bit differently." Any ideas if there could be plans to "unify string cookie parsing" rather then the current platform specific mess, or are things too coupled to the network stacks?
Comment 2 Joseph Pecoraro 2009-08-19 13:00:31 PDT
Totally left that comment on the wrong bug, sorry Rik.
Comment 3 Alexander Pavlov (apavlov) 2010-07-19 01:54:04 PDT
Created attachment 61932 [details] [PATCH] Suggested solution
Comment 4 Alexander Pavlov (apavlov) 2010-07-19 01:59:06 PDT
Created attachment 61933 [details] [PATCH] Code slightly simplified
Comment 5 Pavel Feldman 2010-07-20 05:06:50 PDT
Comment on attachment 61933 [details] [PATCH] Code slightly simplified ~
Comment 6 Alexander Pavlov (apavlov) 2010-07-20 05:21:58 PDT
Committing to http://svn.webkit.org/repository/webkit/trunk ... M WebCore/ChangeLog M WebCore/inspector/front-end/AbstractTimelinePanel.js M WebCore/inspector/front-end/ResourcesPanel.js M WebCore/inspector/front-end/inspector.js Committed r63741