Bug 25058

Summary: Fix chromium build bustage caused by r42216
Product: WebKit Reporter: Darin Fisher (:fishd, Google) <fishd>
Component: WebCore JavaScriptAssignee: Darin Fisher (:fishd, Google) <fishd>
Status: RESOLVED FIXED    
Severity: Normal CC: mbelshe, sam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
v1 patch
dglazkov: review+
v2 patch dglazkov: review+

Description Darin Fisher (:fishd, Google) 2009-04-06 10:55:35 PDT
Fix chromium build bustage caused by r42216

That change included the following patch to DOMWindow.idl:http://trac.webkit.org/changeset/42216/trunk/WebCore/page/DOMWindow.idl

Those changes should have used the JSC prefix for Custom attributes.  Patch coming up...
Comment 1 Darin Fisher (:fishd, Google) 2009-04-06 11:10:20 PDT
Created attachment 29280 [details]
v1 patch
Comment 2 Dimitri Glazkov (Google) 2009-04-06 11:16:55 PDT
Comment on attachment 29280 [details]
v1 patch

Ok.
Comment 3 Darin Fisher (:fishd, Google) 2009-04-06 11:24:02 PDT
Landed as:  http://trac.webkit.org/changeset/42249
Comment 4 Darin Fisher (:fishd, Google) 2009-04-06 11:42:10 PDT
Whoops, that was not quite right.  I revert this in r42250.
Comment 5 Darin Fisher (:fishd, Google) 2009-04-06 13:36:55 PDT
Created attachment 29287 [details]
v2 patch

Version 2, which actually works.  It turns out that you cannot combine CustomGetter and CustomSetter.  So, now I am using JSCCustom and V8CustomSetter.
Comment 6 Dimitri Glazkov (Google) 2009-04-06 13:47:21 PDT
Comment on attachment 29287 [details]
v2 patch

This one better work.
Comment 7 Darin Fisher (:fishd, Google) 2009-04-06 13:49:31 PDT
http://trac.webkit.org/changeset/42254