Bug 24430

Summary: QTMovie fires notifications during view setup
Product: WebKit Reporter: Eric Carlson <eric.carlson>
Component: WebCore Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal    
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.5   
Attachments:
Description Flags
proposed patch koivisto: review+

Description Eric Carlson 2009-03-06 11:35:56 PST
MediaPlayerPrivate::createQTMovieView should postpone notification processing while allocating and setting up the QTMovieView because the QTMovie is active and load state change notifications *do* sometimes fire during (at least) the call to [QTMovieView setView:].
Comment 1 Eric Carlson 2009-03-06 11:36:57 PST
Created attachment 28368 [details]
proposed patch
Comment 2 Mark Rowe (bdash) 2009-03-06 14:35:14 PST
*** Bug 24428 has been marked as a duplicate of this bug. ***
Comment 3 Mark Rowe (bdash) 2009-03-06 14:35:22 PST
*** Bug 24429 has been marked as a duplicate of this bug. ***
Comment 4 David Levin 2009-04-08 16:28:42 PDT
Previously committed <http://trac.webkit.org/changeset/41497>