Bug 239872

Summary: Web Inspector: Regression(r267038) Import a timeline does not render the timeline, only lists the events
Product: WebKit Reporter: Patrick Angle <pangle>
Component: Web InspectorAssignee: Patrick Angle <pangle>
Status: RESOLVED FIXED    
Severity: Normal CC: ews-watchlist, hi, inspector-bugzilla-changes, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Attachments:
Description Flags
Patch v1.0
none
Patch v1.1 ews-feeder: commit-queue-

Description Patrick Angle 2022-04-28 14:30:01 PDT
<rdar://91816187>
Comment 1 Patrick Angle 2022-04-28 18:16:46 PDT
Created attachment 458560 [details]
Patch v1.0
Comment 2 Devin Rousso 2022-04-29 12:14:55 PDT
Comment on attachment 458560 [details]
Patch v1.0

View in context: https://bugs.webkit.org/attachment.cgi?id=458560&action=review

r=me, nice fix =D

> Source/WebInspectorUI/ChangeLog:18
> +        The second issue is that when importing a timeline, we should ignore the current capturing state when setting
> +        the current, start, and end times, otherwise not all the values will be commited since most likely no recording
> +        is in progress at the same time a recording is being imported.

Along these lines, i feel like we should always ignore the current capturing state.  We don't want an imported recording to suddenly start showing new data because we started another recording.

> Source/WebInspectorUI/UserInterface/Views/TimelineRecordingContentView.js:127
> +            this._updateTimes(startTime, endTime, endTime, {fromImport: true});

NIT: do we actually need a parameter, or can we just use `this._recording.imported` instead at each usage?
Comment 3 Patrick Angle 2022-04-29 13:45:50 PDT
Created attachment 458606 [details]
Patch v1.1
Comment 4 EWS 2022-04-29 14:51:30 PDT
Committed r293631 (250137@main): <https://commits.webkit.org/250137@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 458606 [details].