Bug 23939

Summary: Release build being built with debugging symbols
Product: WebKit Reporter: Gustavo Noronha (kov) <gns>
Component: WebKitGTKAssignee: Gustavo Noronha (kov) <gns>
Status: RESOLVED FIXED    
Severity: Normal CC: calvin.walton
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: All   
Attachments:
Description Flags
proposed fix ap: review+

Description Gustavo Noronha (kov) 2009-02-12 16:55:37 PST
The autoconf build system was recently modified to call AC_PROG_CXX. This macro is adding -g and -O2 to CXXFLAGS, which ends up making the build have debug symbols.
Comment 1 Gustavo Noronha (kov) 2009-02-12 17:29:37 PST
Created attachment 27634 [details]
proposed fix

While searching for a way to protect CXXFLAGS from modification I found webkit.m4 where WEBKIT_INIT (which is called by our configure.ac) is defined. There is already an AC_PROG_CXX call there, which protects CXXFLAGS against changes, and which is expanded as part of WEBKIT_INIT, so adding a second call without the protection is no good.

I tested automake1.10 here after removing the second call, and it did not complain about it missing, so I am not sure an issue actually exists.
Comment 2 Calvin Walton 2009-02-12 20:57:03 PST
I'm afraid to say this is my fault, due to a computer that had a broken autotools installation. The original code was in fact correct, and this change should be reverted.
Comment 3 Alexey Proskuryakov 2009-02-16 02:31:28 PST
Comment on attachment 27634 [details]
proposed fix

rs=me
Comment 4 Gustavo Noronha (kov) 2009-02-17 04:49:03 PST
Landed in r41038.