Bug 239361

Summary: Use WebCoreBuiltinNames when possible
Product: WebKit Reporter: Chris Dumez <cdumez>
Component: BindingsAssignee: Chris Dumez <cdumez>
Status: RESOLVED FIXED    
Severity: Normal CC: ashvayka, benjamin, calvaris, cdumez, changseok, darin, eric.carlson, esprehn+autocc, ews-watchlist, glenn, gyuyoung.kim, jer.noble, philipj, sam, sergio, webkit-bug-importer, youennf, ysuzuki
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=239408
Attachments:
Description Flags
Patch
none
Patch none

Description Chris Dumez 2022-04-14 17:09:08 PDT
Use WebCoreBuiltinNames when possible to avoid unnecessary calls to Identifier::fromString(). This is more efficient.
Comment 1 Chris Dumez 2022-04-14 17:10:24 PDT
Created attachment 457657 [details]
Patch
Comment 2 Yusuke Suzuki 2022-04-14 17:20:16 PDT
Comment on attachment 457657 [details]
Patch

r=me
Comment 3 Chris Dumez 2022-04-14 17:57:45 PDT
Created attachment 457658 [details]
Patch
Comment 4 EWS 2022-04-14 22:45:37 PDT
Committed r292899 (249669@main): <https://commits.webkit.org/249669@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 457658 [details].
Comment 5 Radar WebKit Bug Importer 2022-04-14 22:46:14 PDT
<rdar://problem/91796246>
Comment 6 Darin Adler 2022-04-15 14:08:31 PDT
Comment on attachment 457658 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=457658&action=review

> Source/WebCore/bindings/js/WebCoreJSClientData.h:211
> +ALWAYS_INLINE WebCoreBuiltinNames& webCoreBuiltinNames(JSC::VM& vm)

Why not call this WebCore::builtInNames instead of WebCore::webCoreBuiltinNames?