Summary: | Add HTMLInputElement, HTMLOptionsCollection V8 custom bindings | ||||||
---|---|---|---|---|---|---|---|
Product: | WebKit | Reporter: | Dimitri Glazkov (Google) <dglazkov> | ||||
Component: | WebCore Misc. | Assignee: | Dimitri Glazkov (Google) <dglazkov> | ||||
Status: | RESOLVED FIXED | ||||||
Severity: | Normal | ||||||
Priority: | P2 | ||||||
Version: | 528+ (Nightly build) | ||||||
Hardware: | All | ||||||
OS: | All | ||||||
Attachments: |
|
Description
Dimitri Glazkov (Google)
2009-02-10 09:21:41 PST
Created attachment 27520 [details]
Add HTMLInputElement and HTMLOptionsCollection V8 custom bindings
WebCore/ChangeLog | 15 +++
.../v8/custom/V8HTMLInputElementCustom.cpp | 124 ++++++++++++++++++++
.../v8/custom/V8HTMLOptionsCollectionCustom.cpp | 75 ++++++++++++
3 files changed, 214 insertions(+), 0 deletions(-)
Comment on attachment 27520 [details]
Add HTMLInputElement and HTMLOptionsCollection V8 custom bindings
A couple style issues:
62 if (!isnan(v) && !isinf(v)) {
63 if (v < 0.0) {
64 ec = INDEX_SIZE_ERR;
65 } else if (v > static_cast<double>(UINT_MAX)) {
66 newLength = UINT_MAX;
67 } else {
68 newLength = static_cast<unsigned>(v);
69 }
70 }
71 if (!ec) imp->setLength(value->Uint32Value(), ec);
Otherwise looks great.
We need to find a better name for V8Proxy.
Landed as http://trac.webkit.org/changeset/40833 |