Bug 23347

Summary: Compilation of JavaScriptCore/wtf/ThreadingPthreads.cpp fails
Product: WebKit Reporter: Craig Schlenter <craig.schlenter>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: gns, webkit
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
Attachments:
Description Flags
patch to fix compiler error darin: review+

Description Craig Schlenter 2009-01-15 05:54:36 PST
When I try to compile r39933 on linux, the compilation of JavaScriptCore/wtf/ThreadingPthreads.cpp fails because INT_MAX is not defined. Including limits.h fixes this. I'll attach a patch. I have not tested this on other platforms.
Comment 1 Craig Schlenter 2009-01-15 05:56:19 PST
Created attachment 26752 [details]
patch to fix compiler error
Comment 2 Darin Adler 2009-01-15 08:19:54 PST
Comment on attachment 26752 [details]
patch to fix compiler error

r=me
Comment 3 Darin Adler 2009-01-15 10:29:28 PST
*** Bug 23350 has been marked as a duplicate of this bug. ***
Comment 4 Darin Adler 2009-01-15 13:05:51 PST
*** Bug 23353 has been marked as a duplicate of this bug. ***
Comment 5 Alexey Proskuryakov 2009-01-15 13:32:41 PST
Committed as <http://trac.webkit.org/changeset/39945>.