Bug 232711

Summary: AX: rename actionVerb() as localizedActionVerb()
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia>
Component: AccessibilityAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: aboxhall, andresg_22, apinheiro, cfleizach, dmazzoni, ews-watchlist, jcraig, jdiggs, samuel_white, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 230253    
Attachments:
Description Flags
Patch andresg_22: review+

Description Carlos Garcia Campos 2021-11-04 06:48:28 PDT
Since it's returning the localized name. In ATSPI there are two methods in the action interface GetName and GetLocalizedName so we need both.
Comment 1 Radar WebKit Bug Importer 2021-11-04 06:48:42 PDT
<rdar://problem/85015496>
Comment 2 Carlos Garcia Campos 2021-11-04 06:51:08 PDT
Created attachment 443301 [details]
Patch
Comment 3 Andres Gonzalez 2021-11-04 07:16:00 PDT
(In reply to Carlos Garcia Campos from comment #2)
> Created attachment 443301 [details]
> Patch

--- a/Source/WebCore/accessibility/AccessibilityRenderObject.cpp
+++ a/Source/WebCore/accessibility/AccessibilityRenderObject.cpp

-String AccessibilityRenderObject::actionVerb() const
...

So this was duplicated in the subclass? Thanks for cleaning that up!
Comment 4 Carlos Garcia Campos 2021-11-04 07:21:47 PDT
(In reply to Andres Gonzalez from comment #3)
> (In reply to Carlos Garcia Campos from comment #2)
> > Created attachment 443301 [details]
> > Patch
> 
> --- a/Source/WebCore/accessibility/AccessibilityRenderObject.cpp
> +++ a/Source/WebCore/accessibility/AccessibilityRenderObject.cpp
> 
> -String AccessibilityRenderObject::actionVerb() const
> ...
> 
> So this was duplicated in the subclass? Thanks for cleaning that up!

Yes, almost duplicated, the base class handles menu actions too.
Comment 5 Carlos Garcia Campos 2021-11-05 01:23:49 PDT
Committed r285340 (243901@main): <https://commits.webkit.org/243901@main>