Bug 231977

Summary: REGRESSION (r284220): [PAL] TCCSPI.h should be a project header, not a private header
Product: WebKit Reporter: David Kilzer (:ddkilzer) <ddkilzer>
Component: PlatformAssignee: David Kilzer (:ddkilzer) <ddkilzer>
Status: RESOLVED FIXED    
Severity: Normal CC: eric.carlson, katherine_cheney, webkit-bug-importer, wenson_hsieh
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 231621    
Bug Blocks:    
Attachments:
Description Flags
Patch v1 none

Description David Kilzer (:ddkilzer) 2021-10-19 12:41:20 PDT
TCCSPI.h should be a project header, not a private header.

Regressed in r284220 for Bug 231621.

<rdar://problem/84425384>
Comment 1 David Kilzer (:ddkilzer) 2021-10-19 12:47:33 PDT
Created attachment 441772 [details]
Patch v1
Comment 2 Wenson Hsieh 2021-10-19 12:48:09 PDT
Comment on attachment 441772 [details]
Patch v1

r=mews
Comment 3 David Kilzer (:ddkilzer) 2021-10-19 13:40:19 PDT
Comment on attachment 441772 [details]
Patch v1

There are a quorum of successful Apple Cocoa builds, so marking cq+ since this patch is needed to fix builds on other internal build systems.

Note that ios, tv and tv-sim builders seem to be stuck on obsolete patches, and the mac build is ongoing (orange bubble is due to failed jinja Python module install, which isn't a hard failure, and is being investigated by Jonathan Bedard).
Comment 4 EWS 2021-10-19 14:10:46 PDT
Committed r284494 (243248@main): <https://commits.webkit.org/243248@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 441772 [details].