Bug 23188

Summary: Need to cleanup all the names of state functions in AnimationBase
Product: WebKit Reporter: Chris Marrin <cmarrin>
Component: CSSAssignee: Chris Marrin <cmarrin>
Status: RESOLVED FIXED    
Severity: Normal CC: dino, menard, simon.fraser
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.5   
Attachments:
Description Flags
Patch to clean up Animation
none
Same patch with no license changes. none

Description Chris Marrin 2009-01-08 10:09:18 PST
There are many functions in AnimationBase (like isNew() and postactive()) which tell you which state or states the state machine is in. But they are really confusing, both in how they are named and what they actually mean. These should all be cleaned up
Comment 1 Simon Fraser (smfr) 2009-01-08 10:20:04 PST
Also willNeedService() needs a better name.
Comment 2 Simon Fraser (smfr) 2009-02-03 17:50:42 PST
Also:

In Animation:

    bool direction() const { return m_direction; }
This needs to have an enum.
    int iterationCount() const { return m_iterationCount; }
This needs a constant for the magic "-1" value.
Comment 3 Simon Fraser (smfr) 2009-02-03 17:50:47 PST
*** Bug 23513 has been marked as a duplicate of this bug. ***
Comment 4 Simon Fraser (smfr) 2009-02-12 12:21:13 PST
Created attachment 27617 [details]
Patch to clean up Animation
Comment 5 Simon Fraser (smfr) 2009-02-12 12:35:12 PST
Created attachment 27620 [details]
Same patch with no license changes.
Comment 6 Dave Hyatt 2009-02-12 12:35:45 PST
Comment on attachment 27620 [details]
Same patch with no license changes.

r=me
Comment 7 Simon Fraser (smfr) 2009-02-12 12:47:43 PST
Comment on attachment 27620 [details]
Same patch with no license changes.

Landed:
Committing to http://svn.webkit.org/repository/webkit/trunk ...
	M	WebCore/ChangeLog
	M	WebCore/css/CSSComputedStyleDeclaration.cpp
	M	WebCore/platform/animation/Animation.cpp
	M	WebCore/platform/animation/Animation.h
	M	WebCore/platform/graphics/mac/GraphicsLayerCA.mm
Committed r40923
Comment 8 Brent Fulgham 2009-02-13 11:41:53 PST
Closing bug as it has been committed to the archive.
Comment 9 Simon Fraser (smfr) 2009-02-13 11:49:12 PST
There's more cleanup to do (specifically, willGetService()).
Comment 10 Eric Seidel (no email) 2009-04-29 14:56:25 PDT
Comment on attachment 27620 [details]
Same patch with no license changes.

Historically we've tried for one-bug-per-change.  But if you'd like to leave this open, we should at least clear the review flag to remove it from the commit queue.  (Eventually we should just fix the commit queue query).
Comment 11 Alexis Menard (darktears) 2012-12-12 06:11:58 PST
I think all the cleanup landed. I can't find any trace of the old confusing names.