Bug 231564

Summary: [GTK] WebKitURISchemeRequest is missing functions to get headers and methods
Product: WebKit Reporter: Yu-Wei Wu <wusyong9104>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: bugs-noreply, mcatanzaro
Priority: P3 Keywords: Gtk
Version: Other   
Hardware: PC   
OS: Linux   
See Also: https://bugs.webkit.org/show_bug.cgi?id=203273

Description Yu-Wei Wu 2021-10-12 01:17:28 PDT
Unlike WebKitURIRequest which can get the HTTP methods and headers, WebKitURISchemeRequest doesn't have these functions.
Even if I tried to get it through connecting "resource-load-started" signal of the webview, the header of this WebKitURIRequest will still be empty.
It would be nice if WebKitURISchemeRequest can get the headers and methods since this type is the main type used when defining a new URL scheme.
This is useful when it needs to load huge files like videos and the requests have some headers to query in a reasonable range.
Comment 1 Michael Catanzaro 2021-10-18 11:25:56 PDT
Getter for the method is added in bug #231880.
Comment 2 Michael Catanzaro 2021-11-04 05:43:50 PDT
And for headers in bug #203273. Closing.

*** This bug has been marked as a duplicate of bug 203273 ***