Bug 23099

Summary: [GTK] Cannot log in to abclinuxu.cz
Product: WebKit Reporter: Alois Nespor <alois.nespor>
Component: Page LoadingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Major CC: a.butenka, alois.nespor, jmalonzo
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
URL: http://www.abclinuxu.cz/Profile?action=login
Attachments:
Description Flags
Page after login
none
Login page
none
GtkLauncher none

Description Alois Nespor 2009-01-04 06:28:42 PST
Hello,
I have a problem with logging on abclinuxu.cz, you can not log shows the error - see the picture.
Comment 1 Alois Nespor 2009-01-04 06:29:40 PST
Created attachment 26411 [details]
Page after login
Comment 2 Alois Nespor 2009-01-04 06:30:24 PST
Created attachment 26412 [details]
Login page
Comment 3 Alois Nespor 2009-01-04 06:31:40 PST
Used libwebkit-1.0.3-0.39572 and Midori 0.1.1
Comment 4 Robert Blaut 2009-01-04 06:36:13 PST
*** Bug 23098 has been marked as a duplicate of this bug. ***
Comment 5 Jan Alonzo 2009-07-17 16:31:25 PDT
(In reply to comment #3)
> Used libwebkit-1.0.3-0.39572 and Midori 0.1.1

Can you please try again with WebKitGtk 1.1.10 or 1.1.11? Thanks.
Comment 6 Alois Nespor 2009-07-18 01:10:41 PDT
Hello,
I tested now libwebkit 1.10 with libsoup 2.26.3 and midori 0.1.7 and same problem.

I tested also webkitgtk (http://live.gnome.org/WebKitGtk -SVN version 46086) with libsoup from GIT and midori from GIT, but same problem.

I tested also arora (QT4 webkit browser - http://code.google.com/p/arora/) and all is OK.

It will not be a problem with MIDORI?
Comment 7 Jan Alonzo 2009-07-18 01:12:18 PDT
(In reply to comment #6)
> Hello,
> I tested now libwebkit 1.10 with libsoup 2.26.3 and midori 0.1.7 and same
> problem.
> 
> I tested also webkitgtk (http://live.gnome.org/WebKitGtk -SVN version 46086)
> with libsoup from GIT and midori from GIT, but same problem.
> 
> I tested also arora (QT4 webkit browser - http://code.google.com/p/arora/) and
> all is OK.
> 
> It will not be a problem with MIDORI?

Can you try it with GtkLauncher? If it works there then it's most likely Midori. Thanks.
Comment 8 Alois Nespor 2009-07-18 01:43:00 PDT
I can't find GtkLauncher in my system, is as part Webkit or webkitgtk ?
Comment 9 Jan Alonzo 2009-07-18 02:51:19 PDT
(In reply to comment #8)
> I can't find GtkLauncher in my system, is as part Webkit or webkitgtk ?

If you build WebKitGtk, it should be in Programs/GtkLauncher.
Comment 10 Alois Nespor 2009-07-18 03:50:20 PDT
tested wit GtkLauncher and same problems
Comment 11 Alois Nespor 2009-07-18 03:50:49 PDT
Created attachment 33022 [details]
GtkLauncher
Comment 12 Alexander Butenko 2009-07-18 10:18:01 PDT
seems that should be yet another bug for libsoup https handling
Comment 13 Alois Nespor 2009-10-16 00:40:55 PDT
midori 0.2.0-1
libunique 1.1.2-1
libsoup 2.28.0-1
libidn 1.15-1
libwebkit 1.1.15.2-1

now works fine, now i can log in to https page.