Bug 229622

Summary: Rename enums in CSSUnitType to CamelCase and remove CSS_ prefix
Product: WebKit Reporter: Kiet Ho <tho22>
Component: CSSAssignee: Kiet Ho <tho22>
Status: NEW ---    
Severity: Normal CC: ahmad.saleem792, calvaris, cdumez, changseok, dino, eric.carlson, esprehn+autocc, ews-watchlist, fmalita, fred.wang, glenn, gyuyoung.kim, jer.noble, kondapallykalyan, macpherson, menard, mifenton, pdr, philipj, sabouhallawa, schenney, sergio, simon.fraser, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch simon.fraser: review+

Description Kiet Ho 2021-08-27 12:17:54 PDT
Rename enums in CSSUnitType to CamelCase and remove CSS_ prefix.

Most renames follow the format CSSUnitType::CSS_XXX_YYY => CSSUnitType::XxxYyy except for:
* If there exists a method CSSPrimitiveValue::IsXXXX(), then it's renamed to CssUnitType::XXXX instead. For example, CSS_VW is renamed to ViewportPercentageWidth because of CSSPrimitiveValue::IsViewportPercentageWidth()
* CSS_S is renamed to Second

Feel free to comment if you think an enum should be renamed to something else.
Comment 1 Kiet Ho 2021-08-27 12:34:31 PDT
Created attachment 436657 [details]
Patch
Comment 2 Kiet Ho 2021-08-27 14:29:12 PDT
Created attachment 436675 [details]
Patch
Comment 3 Simon Fraser (smfr) 2021-08-27 14:35:54 PDT
Comment on attachment 436675 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=436675&action=review

> Source/WebCore/css/CSSUnits.h:64
> +    DotsPerInch = 31,
> +    DotsPerCentimeter = 32,

We use Cm and In above so these should be DotsPerCm and DotsPerIn
Comment 4 Kiet Ho 2021-08-27 14:50:53 PDT
(In reply to Simon Fraser (smfr) from comment #3)
> Comment on attachment 436675 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=436675&action=review
> 
> > Source/WebCore/css/CSSUnits.h:64
> > +    DotsPerInch = 31,
> > +    DotsPerCentimeter = 32,
> 
> We use Cm and In above so these should be DotsPerCm and DotsPerIn

Or we could change Cm => Centimeter and In => Inch, let me know your preference.
Comment 5 Kiet Ho 2021-08-30 09:52:53 PDT
I'm putting on hold before https://bugs.webkit.org/show_bug.cgi?id=229672 and https://bugs.webkit.org/show_bug.cgi?id=204276 is resolved.
Comment 6 Radar WebKit Bug Importer 2021-09-03 12:18:17 PDT
<rdar://problem/82734077>
Comment 7 Ahmad Saleem 2022-10-09 06:11:58 PDT
It seems that r+ patch didn't landed and this change is also not implemented. Example:

https://github.com/WebKit/WebKit/blob/387077670b14ff83b0f1ea2c1f65be35ad962ad0/Source/WebCore/animation/CSSPropertyAnimation.cpp#L472

Do we need this? Thanks!