Bug 228970

Summary: REGRESSION (r273072): Caps lock indicator in password field is too large
Product: WebKit Reporter: Aditya Keerthi <akeerthi>
Component: FormsAssignee: Aditya Keerthi <akeerthi>
Status: RESOLVED FIXED    
Severity: Normal CC: cdumez, esprehn+autocc, ews-watchlist, glenn, gyuyoung.kim, macpherson, menard, webkit-bug-importer, wenson_hsieh, zalan
Priority: P2 Keywords: InRadar
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=229062
Attachments:
Description Flags
Patch
none
Patch ews-feeder: commit-queue-

Description Aditya Keerthi 2021-08-10 14:21:04 PDT
...
Comment 1 Aditya Keerthi 2021-08-10 14:21:16 PDT
rdar://81546781
Comment 2 Aditya Keerthi 2021-08-10 14:28:09 PDT
Created attachment 435293 [details]
Patch
Comment 3 Wenson Hsieh 2021-08-10 14:30:10 PDT
Comment on attachment 435293 [details]
Patch

r=mews
Comment 4 Aditya Keerthi 2021-08-10 14:44:14 PDT
Thanks for the review! Will wait on EWS.
Comment 5 Aditya Keerthi 2021-08-10 20:07:59 PDT
Created attachment 435319 [details]
Patch
Comment 6 Aditya Keerthi 2021-08-10 20:09:10 PDT
Latest patch fixes the added test on iOS, and skips the test on WK1 due to a lack of support for toggling caps lock key state in DumpRenderTree.
Comment 7 EWS 2021-08-11 13:19:41 PDT
Committed r280927 (240445@main): <https://commits.webkit.org/240445@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 435319 [details].