Bug 226670

Summary: REGRESSION(r275765) When ignoring HSTS, sometimes loads fail
Product: WebKit Reporter: Alex Christensen <achristensen>
Component: New BugsAssignee: Alex Christensen <achristensen>
Status: RESOLVED FIXED    
Severity: Normal CC: cdumez, darin, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 224340    
Attachments:
Description Flags
Patch
none
Patch none

Description Alex Christensen 2021-06-04 17:41:47 PDT
REGRESSION(r275765) When ignoring HSTS, sometimes loads fail
Comment 1 Alex Christensen 2021-06-04 17:42:41 PDT
Created attachment 430635 [details]
Patch
Comment 2 Alex Christensen 2021-06-04 17:43:20 PDT
Created attachment 430636 [details]
Patch
Comment 3 Chris Dumez 2021-06-04 17:44:06 PDT
Comment on attachment 430636 [details]
Patch

Why don't we treat warnings as errors in WebKit2? Seems we should have gotten an unused parameter warning here..
Comment 4 Alex Christensen 2021-06-04 17:45:30 PDT
Comment on attachment 430636 [details]
Patch

We don't treat unused parameters as warnings in ObjC because the language requires unused parameters to be named in selector calls.  We ought to be able to do it for non-selector functions like this, though.
Comment 5 Chris Dumez 2021-06-04 17:50:04 PDT
<rdar://78066692>
Comment 6 EWS 2021-06-04 19:16:05 PDT
Committed r278517 (238516@main): <https://commits.webkit.org/238516@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 430636 [details].
Comment 7 Darin Adler 2021-06-04 21:10:53 PDT
Alex is right. When I turned on unused parameter warnings, I didn’t do it for Objective-C because we’d have to add UNUSED_PARAM in so many places. And I really prefer the "leave out the variable name" over the "use the UNUSED_PARAM macro" style. But that wasn’t a great decision for the ages. I’d love to turn it on now even for the Objective-C files.