Bug 223851

Summary: Enable "hanging" and "each-line" keywords for the text-indent CSS property
Product: WebKit Reporter: Antoine Quint <graouts>
Component: CSSAssignee: Antoine Quint <graouts>
Status: RESOLVED FIXED    
Severity: Normal CC: changseok, esprehn+autocc, ews-watchlist, glenn, gyuyoung.kim, koivisto, kondapallykalyan, ljaehun.lim, macpherson, menard, pdr, webkit-bug-importer, zalan
Priority: P2 Keywords: InRadar, WebExposed
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=240695
Attachments:
Description Flags
Patch
none
Patch
none
Patch koivisto: review+, ews-feeder: commit-queue-

Description Antoine Quint 2021-03-28 03:36:54 PDT
Enable "hanging" and "each-line" keywords for the text-indent CSS property
Comment 1 Antoine Quint 2021-03-28 03:39:06 PDT
The text-indent property has "hanging" and "each-line" keywords which we have code for behind the ENABLE_CSS3_TEXT flag. Chrome exposes them to the Web, and we have good support for it in WebKit that ought to be enabled.
Comment 2 Antoine Quint 2021-03-28 03:49:12 PDT
Created attachment 424490 [details]
Patch
Comment 3 Antti Koivisto 2021-03-28 12:32:02 PDT
Comment on attachment 424490 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=424490&action=review

> Source/WebCore/ChangeLog:13
> +        But LineWidth.cpp already knew how to handle these keywords, so there seems to be no reason to keep
> +        these behind a flag.

Is Alan ok with enabling this feature?
Comment 4 Antoine Quint 2021-03-29 09:36:40 PDT
Created attachment 424537 [details]
Patch
Comment 5 Antoine Quint 2021-03-29 10:56:07 PDT
Created attachment 424548 [details]
Patch
Comment 6 Antoine Quint 2021-03-30 00:41:00 PDT
Committed r275199 (235896@main): <https://commits.webkit.org/235896@main>
Comment 7 Radar WebKit Bug Importer 2021-03-30 00:41:13 PDT
<rdar://problem/75993897>
Comment 8 Kiet Ho 2022-05-19 16:47:17 PDT
*** Bug 112755 has been marked as a duplicate of this bug. ***