Bug 221111

Summary: [webkitcrepy] Handle case where pypi serves invalid html
Product: WebKit Reporter: Jonathan Bedard <jbedard>
Component: Tools / TestsAssignee: Jonathan Bedard <jbedard>
Status: RESOLVED FIXED    
Severity: Normal CC: aakash_jain, ddkilzer, dewei_zhu, slewis, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=221162
Attachments:
Description Flags
Patch none

Description Jonathan Bedard 2021-01-28 16:51:08 PST
In some cases, pypi serves invalid html. At the moment, this is a pretty narrow exception revolving around the <meta> tag.
Comment 1 Jonathan Bedard 2021-01-28 16:52:20 PST
<rdar://problem/73728580>
Comment 2 Jonathan Bedard 2021-01-28 16:57:09 PST
Created attachment 418681 [details]
Patch
Comment 3 David Kilzer (:ddkilzer) 2021-01-28 16:59:46 PST
(In reply to Jonathan Bedard from comment #2)
> Created attachment 418681 [details]
> Patch

ERROR: Tools/Scripts/libraries/webkitcorepy/webkitcorepy/autoinstall.py:131:  invalid escape sequence '\s'  [pep8/W605] [5]
Total errors found: 1 in 4 files

*shrug*
Comment 4 Jonathan Bedard 2021-01-28 17:00:59 PST
(In reply to David Kilzer (:ddkilzer) from comment #3)
> (In reply to Jonathan Bedard from comment #2)
> > Created attachment 418681 [details]
> > Patch
> 
> ERROR: Tools/Scripts/libraries/webkitcorepy/webkitcorepy/autoinstall.py:131:
> invalid escape sequence '\s'  [pep8/W605] [5]
> Total errors found: 1 in 4 files
> 
> *shrug*

Yeah, I don't really understand what it's complaining about. Probably the fact that it should be r'...' instead of b'...' in python 2, but it needs to be b'...' in Python 3, so.....
Comment 5 David Kilzer (:ddkilzer) 2021-01-28 17:02:40 PST
Comment on attachment 418681 [details]
Patch

r=me
Comment 6 EWS 2021-01-28 17:50:35 PST
Committed r272041: <https://trac.webkit.org/changeset/272041>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 418681 [details].