Bug 220540

Summary: REGRESSION(r271341): media/media-fullscreen-inline.html times out on GTK
Product: WebKit Reporter: Philippe Normand <pnormand>
Component: WebKitGTKAssignee: Philippe Normand <pnormand>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, calvaris, cgarcia, eric.carlson, ews-watchlist, glenn, gustavo, jer.noble, menard, philipj, sergio, vjaquez
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=220466
Attachments:
Description Flags
Patch
none
Patch calvaris: review+, ews-feeder: commit-queue-

Description Philippe Normand 2021-01-12 04:41:03 PST
Potentially because GTK doesn't support VIDEO_PRESENTATION_MODE yet. When I run this locally the <video> becomes visible on my desktop, which is very suspicious, because the test harness runs in XvFB...
Comment 1 Philippe Normand 2021-01-12 04:44:30 PST
Expectation updated in r271400
Comment 2 Philippe Normand 2021-05-05 07:30:11 PDT
Created attachment 427765 [details]
Patch
Comment 3 Philippe Normand 2021-05-05 08:15:48 PDT
Created attachment 427767 [details]
Patch
Comment 4 EWS 2021-05-06 04:04:59 PDT
Tools/Scripts/svn-apply failed to apply attachment 427767 [details] to trunk.
Please resolve the conflicts and upload a new patch.
Comment 5 Philippe Normand 2021-05-06 04:12:05 PDT
Committed r277080 (237383@main): <https://commits.webkit.org/237383@main>