Bug 219158

Summary: [JSC] Build failed due to unknown values in LLIntDesiredOffsets.h
Product: WebKit Reporter: Adrian Perez <aperez>
Component: Tools / TestsAssignee: Adrian Perez <aperez>
Status: RESOLVED FIXED    
Severity: Normal CC: annulen, don.olmstead, ews-watchlist, gyuyoung.kim, keith_miller, mark.lam, mcatanzaro, msaboff, ryuan.choi, sbarati, sergio, tzagallo, webkit-bug-importer, ysuzuki
Priority: P2 Keywords: InRadar
Version: WebKit Local Build   
Hardware: PC   
OS: Linux   
Attachments:
Description Flags
Patch ews-feeder: commit-queue-

Description Adrian Perez 2020-11-19 07:04:57 PST
After updating from the repository the following happens:


In file included from ../Source/JavaScriptCore/llint/LLIntOffsetsExtractor.cpp:103:
DerivedSources/JavaScriptCore/LLIntDesiredOffsets.h:610:56: error: use of undeclared identifier 'WasmI32Extend16S_m_dst_index'; did you mean 'WasmI32Load16S_m_dst_index'?
constexpr int64_t constValue607 = static_cast<int64_t>(WasmI32Extend16S_m_dst_index);
                                                       ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
                                                       WasmI32Load16S_m_dst_index
DerivedSources/JavaScriptCore/BytecodeIndices.h:1053:16: note: 'WasmI32Load16S_m_dst_index' declared here
const unsigned WasmI32Load16S_m_dst_index = 0;
               ^
In file included from ../Source/JavaScriptCore/llint/LLIntOffsetsExtractor.cpp:103:
DerivedSources/JavaScriptCore/LLIntDesiredOffsets.h:611:56: error: use of undeclared identifier 'WasmI32Extend16S_m_operand_index'
constexpr int64_t constValue608 = static_cast<int64_t>(WasmI32Extend16S_m_operand_index);
                                                       ^
DerivedSources/JavaScriptCore/LLIntDesiredOffsets.h:612:56: error: use of undeclared identifier 'WasmI32Extend8S_m_dst_index'; did you mean 'WasmI32Load8S_m_dst_index'?
constexpr int64_t constValue609 = static_cast<int64_t>(WasmI32Extend8S_m_dst_index);
                                                       ^~~~~~~~~~~~~~~~~~~~~~~~~~~
                                                       WasmI32Load8S_m_dst_index
DerivedSources/JavaScriptCore/BytecodeIndices.h:1047:16: note: 'WasmI32Load8S_m_dst_index' declared here
const unsigned WasmI32Load8S_m_dst_index = 0;
               ^
In file included from ../Source/JavaScriptCore/llint/LLIntOffsetsExtractor.cpp:103:
DerivedSources/JavaScriptCore/LLIntDesiredOffsets.h:613:56: error: use of undeclared identifier 'WasmI32Extend8S_m_operand_index'
constexpr int64_t constValue610 = static_cast<int64_t>(WasmI32Extend8S_m_operand_index);
                                                       ^
DerivedSources/JavaScriptCore/LLIntDesiredOffsets.h:1103:57: error: use of undeclared identifier 'wasm_i32_extend16_s_length'; did you mean 'wasm_i32_load16_s_length'?
constexpr int64_t constValue1100 = static_cast<int64_t>(wasm_i32_extend16_s_length);
                                                        ^~~~~~~~~~~~~~~~~~~~~~~~~~
                                                        wasm_i32_load16_s_length
../Source/JavaScriptCore/bytecode/Opcode.h:88:22: note: 'wasm_i32_load16_s_length' declared here
    FOR_EACH_WASM_ID(OPCODE_ID_LENGTHS);
                     ^
In file included from ../Source/JavaScriptCore/llint/LLIntOffsetsExtractor.cpp:103:
DerivedSources/JavaScriptCore/LLIntDesiredOffsets.h:1104:57: error: use of undeclared identifier 'wasm_i32_extend8_s_length'; did you mean 'wasm_i32_load8_s_length'?
constexpr int64_t constValue1101 = static_cast<int64_t>(wasm_i32_extend8_s_length);
                                                        ^~~~~~~~~~~~~~~~~~~~~~~~~
                                                        wasm_i32_load8_s_length
../Source/JavaScriptCore/bytecode/Opcode.h:88:22: note: 'wasm_i32_load8_s_length' declared here
    FOR_EACH_WASM_ID(OPCODE_ID_LENGTHS);
                     ^
6 errors generated.
Comment 1 Adrian Perez 2020-11-19 07:06:11 PST
Doing a clean build works, so I suspect this is caused by some
dependency that should trigger the rebuild of LLIntDesiredOffsets.h
not being listed in the corresponding CMake custom_command().
Comment 2 Adrian Perez 2020-11-19 07:52:22 PST
Created attachment 414579 [details]
Patch
Comment 3 Michael Catanzaro 2020-11-19 08:11:47 PST
Comment on attachment 414579 [details]
Patch

Grrr, now this is good proof that I am not smart. I found one file missing in bug #219043 but managed to miss four others. Nice. :P
Comment 4 EWS 2020-11-19 09:37:53 PST
Committed r270036: <https://trac.webkit.org/changeset/270036>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 414579 [details].
Comment 5 Radar WebKit Bug Importer 2020-11-19 09:38:17 PST
<rdar://problem/71589994>