Bug 215295

Summary: Revise ITP and ResourceLoadStatistics naming
Product: WebKit Reporter: Brent Fulgham <bfulgham>
Component: WebKit Misc.Assignee: Nobody <webkit-unassigned>
Status: NEW ---    
Severity: Normal CC: bfulgham, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=215201

Description Brent Fulgham 2020-08-07 15:23:50 PDT
The various ITP-related bits of code in the engine started with the term 'ResourceLoadStatistics', and eventually became part of a group of features collectively labeled "ITP".

We should revise naming of these bits to more truly reflect the jobs they do, and to make understanding the code easier.
Comment 1 Radar WebKit Bug Importer 2020-08-07 15:24:16 PDT
Comment 2 Brent Fulgham 2020-08-07 15:28:40 PDT
This would be a good opportunity to get rid of a number of #ifdef guards as well