Bug 215295 - Revise ITP and ResourceLoadStatistics naming
Summary: Revise ITP and ResourceLoadStatistics naming
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
Keywords: InRadar
Depends on:
Reported: 2020-08-07 15:23 PDT by Brent Fulgham
Modified: 2020-08-07 15:28 PDT (History)
2 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Brent Fulgham 2020-08-07 15:23:50 PDT
The various ITP-related bits of code in the engine started with the term 'ResourceLoadStatistics', and eventually became part of a group of features collectively labeled "ITP".

We should revise naming of these bits to more truly reflect the jobs they do, and to make understanding the code easier.
Comment 1 Radar WebKit Bug Importer 2020-08-07 15:24:16 PDT
Comment 2 Brent Fulgham 2020-08-07 15:28:40 PDT
This would be a good opportunity to get rid of a number of #ifdef guards as well