Bug 214845

Summary: Occasional crashes under PDFPlugin::createScrollbar and PDFPlugin::updateScrollbars
Product: WebKit Reporter: Tim Horton <thorton>
Component: New BugsAssignee: Tim Horton <thorton>
Status: RESOLVED FIXED    
Severity: Normal CC: beidson, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Description Tim Horton 2020-07-27 13:55:49 PDT
Occasional crashes under PDFPlugin::createScrollbar and PDFPlugin::updateScrollbars
Comment 1 Tim Horton 2020-07-27 14:03:54 PDT
Created attachment 405309 [details]
Patch
Comment 2 Tim Horton 2020-07-27 14:03:56 PDT
<rdar://problem/59293598>
Comment 3 Brady Eidson 2020-07-27 14:06:08 PDT
Comment on attachment 405309 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=405309&action=review

> Source/WebKit/ChangeLog:11
> +        No new tests; timing is such that I can't reproduce without inserting
> +        intentional delays into the main thread hops, which is further than
> +        I'm willing to go for a test.

Fair.
Comment 4 Tim Horton 2020-07-27 14:16:00 PDT
Created attachment 405311 [details]
Patch
Comment 5 EWS 2020-07-27 14:57:20 PDT
Committed r264945: <https://trac.webkit.org/changeset/264945>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 405311 [details].