Bug 210988

Summary: [Web Animations] Ensure calling Web Animations APIs override future CSS Animations style properties
Product: WebKit Reporter: Antoine Quint <graouts>
Component: AnimationsAssignee: Antoine Quint <graouts>
Status: RESOLVED FIXED    
Severity: Normal CC: cdumez, dino, esprehn+autocc, ews-watchlist, graouts, kondapallykalyan, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch dino: review+

Description Antoine Quint 2020-04-24 13:08:07 PDT
[Web Animations] Ensure calling Web Animations APIs override future CSS Animations style properties
Comment 1 Antoine Quint 2020-04-24 13:23:28 PDT
Created attachment 397495 [details]
Patch
Comment 2 Dean Jackson 2020-04-24 13:30:49 PDT
Comment on attachment 397495 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=397495&action=review

> Source/WebCore/animation/WebAnimation.cpp:151
> +void WebAnimation::setBindingsEffect(RefPtr<AnimationEffect>&& newEffect)
> +{
> +    setEffect(WTFMove(newEffect));
> +}

Why does this need a different name for bindings? And the other two below.
Comment 3 Antoine Quint 2020-04-24 13:34:16 PDT
(In reply to Dean Jackson from comment #2)
> Comment on attachment 397495 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=397495&action=review
> 
> > Source/WebCore/animation/WebAnimation.cpp:151
> > +void WebAnimation::setBindingsEffect(RefPtr<AnimationEffect>&& newEffect)
> > +{
> > +    setEffect(WTFMove(newEffect));
> > +}
> 
> Why does this need a different name for bindings? And the other two below.

Because CSSAnimation subclasses this method to apply some overrides. This needs to happen only when the effect is set via the JS API.
Comment 4 Antoine Quint 2020-04-24 14:42:59 PDT
Committed r260671: <https://trac.webkit.org/changeset/260671>
Comment 5 Radar WebKit Bug Importer 2020-04-24 14:43:19 PDT
<rdar://problem/62340827>