Bug 209628

Summary: Regression: Unable to trigger context menu on empty tabs in Safari
Product: WebKit Reporter: Chris Dumez <cdumez>
Component: WebKit2Assignee: Chris Dumez <cdumez>
Status: RESOLVED FIXED    
Severity: Normal CC: achristensen, ggaren, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Description Chris Dumez 2020-03-26 16:35:38 PDT
Unable to trigger context menu on empty tabs in Safari.
Comment 1 Chris Dumez 2020-03-26 16:37:39 PDT
Created attachment 394674 [details]
Patch
Comment 2 Geoffrey Garen 2020-03-26 16:40:25 PDT
Comment on attachment 394674 [details]
Patch

r=me

Should we do something specific to skip mouseover and mousemove events? Would be a shame to launch a process just because a view was under the mouse.
Comment 3 Chris Dumez 2020-03-26 16:45:38 PDT
(In reply to Geoffrey Garen from comment #2)
> Comment on attachment 394674 [details]
> Patch
> 
> r=me
> 
> Should we do something specific to skip mouseover and mousemove events?
> Would be a shame to launch a process just because a view was under the mouse.

That is a good idea. I will see how easy that is.
Comment 4 Chris Dumez 2020-03-26 17:54:30 PDT
Created attachment 394684 [details]
Patch
Comment 5 EWS 2020-03-26 18:36:04 PDT
Committed r259097: <https://trac.webkit.org/changeset/259097>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 394684 [details].
Comment 6 Radar WebKit Bug Importer 2020-03-26 18:37:15 PDT
<rdar://problem/60946732>