Bug 206035

Summary: Check the existence of the optional m_sessionID before using it in WebProcess::setResourceLoadStatisticsEnabled()
Product: WebKit Reporter: John Wilander <wilander>
Component: WebKit Misc.Assignee: John Wilander <wilander>
Status: RESOLVED FIXED    
Severity: Normal CC: bfulgham, commit-queue, jbedard, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Local Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=206100
Attachments:
Description Flags
Patch none

Description John Wilander 2020-01-09 14:12:06 PST
Since m_sessionID is optional, we need to check that it exists before asking it whether the session is ephemeral.
Comment 1 John Wilander 2020-01-09 14:12:20 PST
<rdar://problem/58455306>
Comment 2 John Wilander 2020-01-09 14:14:42 PST
Created attachment 387271 [details]
Patch
Comment 3 Brent Fulgham 2020-01-09 15:02:51 PST
Comment on attachment 387271 [details]
Patch

r=me
Comment 4 WebKit Commit Bot 2020-01-09 15:47:42 PST
Comment on attachment 387271 [details]
Patch

Clearing flags on attachment: 387271

Committed r254310: <https://trac.webkit.org/changeset/254310>
Comment 5 WebKit Commit Bot 2020-01-09 15:47:43 PST
All reviewed patches have been landed.  Closing bug.
Comment 6 Jonathan Bedard 2020-01-10 13:46:09 PST
I'm not 100% sure this is the cause, but we have a flakey regression in a resource load statistics test, and this seems like a plausible candidate:

https://results.webkit.org/?suite=layout-tests&test=http%2Ftests%2FresourceLoadStatistics%2Fclassify-as-non-prevalent-based-on-sub-frame-under-top-frame-origins-database.html
Comment 7 Jonathan Bedard 2020-01-10 13:47:23 PST
Although <https://trac.webkit.org/changeset/254296> is also a plausible candidate.
Comment 8 John Wilander 2020-01-10 15:08:42 PST
Thanks for flagging, Jonathan! I'm trying to address the flakiness in https://bugs.webkit.org/show_bug.cgi?id=206100.
Comment 9 John Wilander 2020-01-14 10:49:19 PST
The flaky test looks all green after my latest change.
Comment 10 Jonathan Bedard 2020-01-14 11:22:49 PST
Looks good so far...still need a few more test runs to be confident.
Comment 11 Jonathan Bedard 2020-01-16 15:02:01 PST
I think we can pretty confidently say things are fixed now.