Bug 203421

Summary: Add a test verifying video plays well when switching from MediaStreams to regular videos
Product: WebKit Reporter: youenn fablet <youennf>
Component: WebRTCAssignee: youenn fablet <youennf>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, eric.carlson, ews-watchlist, ggaren, glenn, hta, jer.noble, philipj, sergio, tommyw, webkit-bug-importer, youennf
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch for landing none

Description youenn fablet 2019-10-25 09:47:32 PDT
Add a test verifying video plays well when switching from MediaStreams to regular videos
Comment 1 youenn fablet 2019-10-25 09:49:19 PDT
Created attachment 381934 [details]
Patch
Comment 2 Geoffrey Garen 2019-10-25 10:39:04 PDT
Comment on attachment 381934 [details]
Patch

r=me
Comment 3 Eric Carlson 2019-10-25 11:11:15 PDT
Comment on attachment 381934 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=381934&action=review

> LayoutTests/fast/mediastream/stream-switch.html:17
> +        localVideo.src = "../../media/content/audio-tracks.mp4";

You can make this work cross platform by including "../../media/media-file.js" and using "localVideo.src = findMediaFile('video', 'content/test')"
Comment 4 youenn fablet 2019-11-04 00:36:27 PST
Created attachment 382722 [details]
Patch for landing
Comment 5 WebKit Commit Bot 2019-11-04 03:35:07 PST
Comment on attachment 382722 [details]
Patch for landing

Clearing flags on attachment: 382722

Committed r251982: <https://trac.webkit.org/changeset/251982>
Comment 6 WebKit Commit Bot 2019-11-04 03:35:08 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Radar WebKit Bug Importer 2019-11-04 03:36:20 PST
<rdar://problem/56860567>