Bug 203144

Summary: Move service worker registration matching for navigation loads to network process
Product: WebKit Reporter: youenn fablet <youennf>
Component: Service WorkersAssignee: youenn fablet <youennf>
Status: RESOLVED FIXED    
Severity: Normal CC: achristensen, cdumez, dbates, ews-watchlist, japhet, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Win fix
none
Patch none

youenn fablet
Reported 2019-10-18 01:10:38 PDT
Move service worker registration matching for navigation loads to network process
Attachments
Patch (56.10 KB, patch)
2019-10-18 02:37 PDT, youenn fablet
no flags
Patch (56.18 KB, patch)
2019-10-18 03:20 PDT, youenn fablet
no flags
Win fix (56.17 KB, patch)
2019-10-18 06:44 PDT, youenn fablet
no flags
Patch (53.48 KB, patch)
2019-10-21 15:46 PDT, Alex Christensen
no flags
youenn fablet
Comment 1 2019-10-18 02:37:17 PDT
youenn fablet
Comment 2 2019-10-18 03:20:06 PDT
youenn fablet
Comment 3 2019-10-18 06:44:42 PDT
youenn fablet
Comment 4 2019-10-21 05:41:31 PDT
Ping review. Mac-wk1 tests are not about service workers ( fast/scrolling/latching/scroll-select-bottom-test.html and fast/events/resize-subframe-in-rendering-update.html ), so I doubt this is a regression. Perl bot is failing test262 tests which should not be affected by this patch either.
youenn fablet
Comment 5 2019-10-21 05:42:14 PDT
Also previous patch was passing in WK1 and webkitperl and the changes were #ifdef for WIN compilation.
Chris Dumez
Comment 6 2019-10-21 08:23:37 PDT
Comment on attachment 381299 [details] Win fix View in context: https://bugs.webkit.org/attachment.cgi?id=381299&action=review > Source/WebCore/ChangeLog:8 > + For regular loads, we no longer match service worker registration explicitly. "explicitly" > Source/WebCore/ChangeLog:10 > + We still need to explicitely match registrations in those two cases: "explicitely" -> Make up your mind :P > Source/WebCore/workers/service/server/SWServer.cpp:144 > + m_importCompletedCallbacks.append(WTFMove(callback)); I think we should ASSERT(!m_importCompleted); > Source/WebKit/WebProcess/Storage/WebSWClientConnection.cpp:191 > +void WebSWClientConnection::documentIsControlled(DocumentIdentifier documentIdentifier, ServiceWorkerRegistrationData&& data, CompletionHandler<void(bool)>&& completionHandler) The naming is bad IMO. It looks like a getter but is really a setter. I'd suggest something like setDocumentIsControlled() or controlDocument().
Alex Christensen
Comment 7 2019-10-21 15:46:13 PDT
Alex Christensen
Comment 8 2019-10-21 18:34:53 PDT
Radar WebKit Bug Importer
Comment 9 2019-10-21 18:35:18 PDT
Note You need to log in before you can comment on or make changes to this bug.