Bug 202499

Summary: [iOS] Re-use the node found for generating a context menu's targeted preview when performing a context menu action
Product: WebKit Reporter: Andy Estes <aestes>
Component: PlatformAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal    
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=202498

Description Andy Estes 2019-10-02 15:53:17 PDT
Currently we hit test two times during a context menu interaction: once to generate the targeted preview and once to preform the user's selected action. If these hit-tests return different nodes (because perhaps the page changed in the time between the two hit tests) then we can end up with weird bugs like failing to perform the action or performing the action on the wrong element.
Comment 1 Andy Estes 2019-10-03 01:09:55 PDT

*** This bug has been marked as a duplicate of bug 202510 ***